Jump to content
RockWare Support Forum

All Activity

This stream auto-updates     

  1. Last week
  2. Earlier
  3. 3D resistivity Model

    Hi, Right click on a column title (item #1) and a dialog box will appear (item #2). Select "X or Y Coordinate" (item #3) for the X column and then choose the coordinate system (item #4) that you're using for the resistivity points. Do the same for the Y column. For the Z coordinates, select the "Linear (Z) Dimensions" option (item #5) and the menu will change to show the linear units (e.g. Feet, Meters). Select the appropriate z-units. Now, the datasheet columns should show the units and you're ready to go. These coordinate designations will allow you to have data tables that are not in the same units as your project dimensions (item #6). For example, let's say that you've set your Project Dimensions up in UTM meters but your resistivity data is in State Plane footage coordinates. The program will automatically convert your resistivity coordinates to project coordinates (item #6). This is a big deal for clients who have different data sets in different units. It becomes especially useful when exporting to Google Earth, in which the program will automatically convert everything to longitude/latitude/meters (the only units that Google Earth imports via KMZ files). There's a video button (item #7) that will display a popup menu with four video links. Select the one labeled "Changing Datasheet Names & Column Types". This will launch a 2-minute video that describes all of this in more detail. You can also press the F1 key from within the datasheet editor and navigate to the datasheet documentation for non-video, textual instructions: file:///C:/ProgramData/RockWare/RockWorks17/WebHelp/introduction.htm Also, if you click on the Help button within the Column Parameters dialog you'll see that there are other things that you can do with the column types (e.g. density conversions, hyperlinks, etc.) Good luck and best regards, Jim Reed.
  4. To Rockware Support team, I am looking at using it to produce 3D resistivity model(s). I exported the XYZG file (attached) form the RES3DINV. When i try to produce the 3D block model on rockware, i constantly get the error with the following message: Units Must be Specified for XY column: X(2) and Y(3). I been toiling with this for days now and would like to send-off for advice. 3D block.txt
  5. Cannot install RockWorks 17 silently with SCCM

    It looks like the installation works great unless you use SCCM. Others are able to use SCCM to install the software, so there is something unique about your setup that is causing the problem. I agree that manual installation sounds like the best workaround. If I hear of anything that may help with SCCM deployment, I will post it here. Regards, Tom B RockWare Inc
  6. Cannot install RockWorks 17 silently with SCCM

    Hi Tom, Yes, works perfectly. Tried running the installation script manually, but, got interrupted by an error message (see attached). I tried selecting the "retry" option, but the installation couldn't get past that error. Selecting "ignore" seems to move the installation forward without any other issues. I can run the software without issues. Aaaaaaand, just to complicate things further, I cannot access that log file because SCCM runs the installation as "SYSTEM" user, which does not create a local profile, therefore no files are created in the directory you mentioned. If you have any further ideas, I will definitely take them on board, however, at this stage because the time that this is taking I think I will be forced to arrange for manual installation for our affected computer labs. Thanks for your help...
  7. Cannot install RockWorks 17 silently with SCCM

    Does the Access Violation error occur if you run RockWorks after installing without using SCCM? Does the Access Violation error occur if you run RockWorks after installing with SCCM without the command line switches? Send me the program log with a description of the steps you perform and I'll take a look. The RockWorks program log is at: C:\Users\<username>\AppData\Local\RockWare\RockWorks17\RockWorks_Log.txt Regards, Tom B RockWare Inc
  8. Cannot install RockWorks 17 silently with SCCM

    Oh, here is the log file for the above installation (with the access violation error). RockInst.log
  9. Cannot install RockWorks 17 silently with SCCM

    Hi Tom, %~dp0 is a variable that is used with batch files that expands to the drive letter and path of the location of the batch file. The way SCCM works is that it copies the installation files of a software package down to the local computer, storing the content in a randomly named folder (e.g. "7j") under C:\Windows\ccmcache. Because the folder is randomly named, we cannot know what it will be called on each computer, so that is where %~dp0 comes in to play. Since the batch file is running in the same directory as the executable, I removed the %~dp0 component from the script and it appears to now work and my script runs through to the end. The only issue is when I try running RockWorks I am still seeing the "Access violation at address 00000000000000000 in module 'RockWorks17.exe' error. I tried rebooting the computer as I have seen that working in the past when I have seen that error in testing, however, it hasn't worked this time. Any tips on that error?
  10. Cannot install RockWorks 17 silently with SCCM

    Hi its-desktop, What drive is mapped by the %~dp0 variable? Is this a valid drive? Does your installation batch file create a separate log file? If so, please send it. I am not an expert on SCCM, but others on the web suggest using a pushd %~dp0 to map the drive separately. pushd "%~dp0" setup.exe Replace setup.exe with the RockWorks17_installation.exe command line. Are you able to run the batch file in the same directory as the RockWorks17_installation.exe file? This procedure will remove the %~dp0 variable from the command line so we can see if that is the cause of the problem. Regards, Tom B RockWare Inc
  11. Cannot install RockWorks 17 silently with SCCM

    I tried the above line in my installation script, however, the installation still gets stuck. I could provide my entire installation batch script here, however, it doesn't get past the installation stage, so I will show just up to that point (with your changes from above included): @ECHO OFF REM Install RockWorks 17 "%~dp0rockworks17_installation.exe" /LOG=c:\temp\RockInst.log /TASKS="!registercom" /SILENT /FORCE=TRUE As you can see, there isn't anything too groundbreaking in there. The log file hasn't been created, however, the RockWorks Desktop icon is deployed. When attempting to run the applications, RockWorks shows an error popup with "Access violation at address 00000000000000000 in module 'RockWorks17.exe'. Execution of address 00000000000000000". The other program - RW 15 to 17 Conversion Tool 64bit - appears to be working fine.
  12. Cannot install RockWorks 17 silently with SCCM

    Hi its-desktop, I haven't seen problems with the .TMP files, but there have been issues in the past under SCCM with the ChkMaint.dll and calling RegSrvr to register the RockWorks17.exe file. To work around those problems, add some command line arguments to the installation command: rockworks17_installation.exe /LOG=c:\temp\RockInst.log /TASKS="!registercom" /SILENT /FORCE=TRUE If the problem continues, report the command line that you use and send the .LOG file. We'll take a look. Regards, Tom B
  13. I am attempting to set up a software application in SCCM for RockWorks 17, using the silent parameters that are available for RockWorks, however, each time I try the installation appears to hang. Upon closer inspection in Task Manager, I have discovered that the "rockworks17_installation.exe" is getting stuck - as are the sub programs launched by the main exe such as "rockworks17_installation.tmp" and "_setup64.tmp". The script I am using works perfectly when running through a CMD window, however, it seems to stall when installing as an elevated "SYSTEM" user via SCCM. Any help with this issue would be appreciated.
  14. LogPlot8 2019.3.28

    New versions of LogPlot8 (32-bit and 64-bit) were uploaded to the RockWare website today with the following changes: Enhancements The LAS Import does a better job mapping LAS data fields and the LP data fields. LAS parameter data is imported to Edit text on a tab named after the data section. Tabs with two depths (like Lithology, with a Top and Base depth) both fields are auto mapped. Bug Fix Importing LogPlot 7 data files was only bringing in 1 line of Note Text data. When using the Custom Units per Page option in LogView the Lithology Description and Interval Text columns weren't being clipped correctly. For a complete list of recent changes, please visit: https://www.rockware.com/rockworks/revisions/current_logplot_revisions.htm To download this build, use the Help | Check for Updates menu inside LogPlot8. Or visit the LogPlot Free Trial tab (https://www.rockware.com/product/logplot/) where you can download the installation program and install the new build right over the top of the existing program. (DO NOT UNINSTALL first.) Note that you will not be able to use this new build of the program if your maintenance has expired. If you would like to renew your maintenance, contact RockWare Sales or visit our Customer Portal (https://www.rockware.com/customer) and either create a new account (new visitors) or log in with your existing account. Enjoy! Molly Mayfield RockWare Inc
  15. New versions of RockWorks17 (64- and 32-bit) were uploaded to the RockWare website today, with the following changes: New Features RockWorks17 now supports the import of depth registered raster logs into the Borehole Manager database. Added a program that converts a grid to a solid (Utilities/Solid/Convert/Grid To Solid). Improvements Color Legends in RockPlot3D that use a Custom Color Table will now place the labels at the boundaries if the table is continuous with no gaps. GeoProbe Imports works with OIHP data files. Improved coordinate handling when transferring location data from an .RwDat file to the borehole database. A "Show Label" field has been added to the Color Fill Table. This allows users to pick which labels to display in Color Table Legends in RockPlot3D and RockPlot2D. IHS Energy import can limit Stratigraphy Tops & Bottoms to specific source codes. When copying data to a new project, the project dimensions were not copied correctly when there were subsite values. Improved column sorting in accessory project tables. Bug Fixes The Legend options for 3D Multiple Striplogs weren't being saved. The PLSS Offset vs. quarter/quarter radio buttons on the tabsheet tabs are now both being updated. Made a fix to the Land Grid tab-delimited System Table for custom grid coordinates, it was not loading the entire the point stream. Added a fix to the database's Color Fill table, you can enable/disable all Show Label fields at once. Tabbing thru the last row will now insert an new row as the other tables do. Specifying a column for Easting or Northing columns in Utilities/Map/Grid Based Map that didn't include input units caused the program to keep asking to automatically fix input units. Failure to create a grid in Utilities/Map/Grid Based Map caused an Access Violation error. Fixed some issues displaying Color Tables and modifying label text in RockPlot3D The Recent Projects menu item could cause an Access Violation error in certain circumstances. The Size, Color and Font Name can now be modified in RockPlot3D Bitmap Text. The Declustering Resolution for models and grids can now be set larger than 100%. The RockPlot2D Color Legend using a color table was not plotting the colors or labels correctly when in descending order. In RockPlot3D View nodes can no longer be dragged out of the View set in the data tree. The Title of Views in RockPlot3D are now correctly saved after they've been edited. The transparency setting for raster images in RockPlot3D is now saved. The RockWorks Revision History has a complete list, by date, of these changes since the last update. To download this build, use the Help | Check for Updates menu inside RockWorks17. Or visit our website and click on the RockWorks Free Trial tab: https://www.rockware.com/product/rockworks/ where you can download the installation program and install the new build right over the top of the existing program. (DO NOT uninstall first.) Note that you will not be able to use this new build of the program if your maintenance has expired before March 2019. Contact RockWare Sales or visit our Customer Portal (https://www.rockware.com/customer/) if you would like to update your maintenance. Enjoy! Molly Mayfield RockWare Inc
  16. Sam, You should be able to import this through the Excel|Multiple Tables menu. If the Location and Lithology data have already been imported into the database, you can choose to just import the Stratigraphy by deselecting the Location and Lithology Tables in the Block Selection tab.
  17. From Terra Softa: Saving Files to Protected Folders Windows Defender (when turned on) will prevent you from saving files, especially image files like .wmf files. Since this is unacceptable, the following workaround is important. + Open Windows Defender if you have it running, its icon is a shield. + Click: Virus & threat protection settings (scroll down to find Controlled folder access). + Click: Manage Controlled folder access. + Click: Allow an app through Controlled folder access. + Click: Add an allowed app. This opens up a file dialog that you use to find the Igpet EXE file so you can select it for access to protected folders (e.g. Desktop, Documents). Igpet_WinYEAR.exe is what you are looking for. It should be in the directory: C:\Program Files (x86)\IgpetYEAR. + Click on the Igpet_WinYEAR.exe file and answer Yes when asked to approve. + Finally, restart your PC so the changes in Windows Defender can take effect. + Do the same with the Mixing.exe and CipwPlus.exe programs to more easily use them. Now Igpet will work quite a lot better.
  18. Hi Sorry I know this is a very easy question but it been a while since i've used the software and i'm struggling to remember certain functions. I'm trying to append strat data to borehole I already have imported as locations and depth in RockWorks 17. The attached img shows how I have the strat data stored. I remember how to append data when it has been formatted in rows but cant remember when its in columns via depth? Im sure there is a tutorial page for this but I can only find those that refer to importing via rows.
  19. Cannot Open Rockworks 17

    We received the bug report and found that the error was related to syncing to OneDrive. The user was able to resolve the problem by turning off syncing or moving to a different folder. Tom B RockWare Inc
  20. 3D Stratigraphic model

    Mr TOM, is there a possibility to delete my files that I attached to the forum (geol map, excel files...) because I can't delete them. Thank you very much.
  21. 3D Stratigraphic model

    Thank you very much Mr TOM for responding to me quite quickly, on my side I will try to apply what you advised me to do. In the meantime, please believe Mr. Tom in the assurance of my perfect considerations, thank you very much. Slimane
  22. 3D Stratigraphic model

    Hi Slimane, The Stratigraphy model does not match the geology map due to lack of data and the way missing formations are modeled. You may want to add data at the formation contacts on the geologic map representing the base of the younger formation and the top of the older formation. In your data, missing formations are left blank. Since there are no data points to constrain the data, RockWorks looks to other nearby wells where there are data for each formation. You may want to add missing formations with the same top and base depth (zero thickness) to help the model define the areas where the formation has been eroded away. Regards, Tom B RockWare Inc
  23. 3D Stratigraphic model

    Hello Mr. TOM, I would be very grateful if you could help me. Before explaining my problem, let me inform you that I am studying in 3rd year doctoral studies in hydrogeology (my theme is based on the combination of the geology of a region in southern Algeria with hydrochemical data) where I am obliged to use the famous Rockwork software (Version 17) to establish a 3D stratigraphic model. Allow me, Mr TOM, to explain the problem to you that I have not been able to solve it for several weeks. I can't make my 3D stratigraphic model concrete (in relation to my geological map of the study area). I send you my excel file (database) with the model I obtained and the geological map. I would be very grateful for your help and collaboration. Thank you very much. RW_Mars_18-03-2019.zip RockWorks data import 2019.xls (links removed per user request - admin) (geologic map removed per user request - admin)
  24. Cannot Open Rockworks 17

    I tried your suggestion and still have the same problem. I have created a bug report and sent it on to [email protected] I hope to hear from them soon. Thanks Mike
  25. Cannot Open Rockworks 17

    Good morning Mike, The error you are receiving is likely because your data dictionary is corrupted. I would suggest either deleting, or renaming the system folder for that project and that would let RockWorks rebuild the sql database again and see if that resolves the issue. If you receive the error again could you select Report Error / Restart and send the bug report to [email protected] so we could take a look at that as well?
  26. Cannot Open Rockworks 17

    Thanks Paul I set up a new project in the C: folder and I still get the following error as well as all the others. I do not have any data in any projects as I'm just getting started in RockWare. All I have done is gone through the tutorials. This is a bit frustrating, but I'm wondering if I should uninstall the program and re-load it or re-set the SQL data base?. There appears to be something corrupted somewhere. I appreciate your help. Mike
  27. Hi Thaïsa, I have enclosed a screen shot of one of the polygon RwDat files, and the "master" RwDat file that references each polygon file name and elevation. The "z" column is not needed in the polyg RwDat file for this application. The "cutoff value" is not present in versions that have the new functionality. You may need to update to a newer build. The feature was added in the 2017.8.21 build. Regards, Tom B RockWare Inc
  1. Load more activity