Jump to content
RockWare Support Forum
Will

Model Boundary Clipping and Extents

Recommended Posts

Hello Rockworkers,

I have been struggling with an issue for a day or two now that I would like to resolve. I have a number of boreholes with I-data concentration values that I would like to model to my site boundary. I have created the necessary .tab file to filter to my polygon boundary. The model that is created is very rigid; is there a way to smooth these or get a true clip of the model? Maybe increase the models resolution? I would also like to extend the model to the extent of the site/model boundary. Is this as easy as setting the project dimensions past the spatial extent of the boreholes and furthermore the site boundary?

Thank you

Will

post-528-1226067326_thumb.jpg

Share this post


Link to post
Share on other sites

Hi Will,

Some general concepts:

1. If you use the Scan All Boreholes button to define your Project Dimensions, these dimensions will be set just outside the extents of the boreholes along all three axes. Should you need to enlarge the area for the entire site boundary, just edit the min and max coordinates accordingly. The scan buttons are there for convenience but you can certainly manually define the X,Y,Z boundaries of your project as you wish.

2. The Spacing settings in the Project Dimensions pane are really important. The define the density of nodes that will make up your grid models (XY only) and your solid models (XYZ). The XY spacing should be set to no greater than half the average minimum distance between your boreholes. (Tip: create a quick borehole location map and use RockPlot's Measure / Distance tool to determine the distance between your holes.) The Z spacing should, if possible, be about half of your typical downhole i-data spacing. (If you have measurements every foot, for example, you could try the Z spacing at 0.5 feet.) In general, the finer the MOD file (more nodes, tighter spacing) the smoother the graphic output representing the MOD file. Though if you create a too-fine model you'll grow old waiting for the model to be generated and rendered.

3. The Polygon Filter (under Model Constraints or as a stand-alone filter in the RockWorks Utilities Solid / Filter menu) does not change the XY extents of the model. Instead, it just tells the program to hide (set to null-value) nodes inside or outside the polygonal area. So, you could set the Project Dimensions slightly beyond your site boundary, and then use the polygon filter to pull it in to the boundary extents. Do note that if your boreholes are not close to the site boundary, the edge nodes that are interpolated may not be very accurate simply because there are not a lot of control points to draw from.

4. In a similar manner, the Model Constraints / Upper and Lower Grid Surface Filters tell the program to hide nodes that lie above/below these surfaces, but (again) don't affect the elevation extents of the model.

5. Once you've defined the Project Dimensions, enabled any model-constraining filters, and generated the model, you can then fiddle with what is displayed in RockPlot3D. Just double-click on the Isosurface item or All-Voxel item in the Data pane to access the Options window. There you can filter the G values displayed (and see the volume updated), adjust the color scheme and draw style, etc.

Does this help? Please feel free to zip and email your project's MDB file to me if you want specific questions answered.

Molly

RockWare Inc

[email protected]

Share this post


Link to post
Share on other sites

Molly,

You have been very helpful. I will apply your recommendations and I will go from there. I am sure I might have some more questions, if thats the case I will send over the mdb. Thanks again.

Will

Share this post


Link to post
Share on other sites

I have achieved the output I was looking for, except for one issue. When creating the solid diagram in Rockplot3D I have noticed that when I chose the Isosurface option the sidewalls of the solid diagram are one solid color and not an isosurface that it shows in the "All Voxel" option. Is there something I should be doing. I have attached a screen shot. I also have lines that are showing up outside of my polygon clip, not sure how to remove those, although that is not that important.

Also, when setting my project dimensions, I am getting confused. I am creating an I-data model. I have X,Y,Z data and then I have my Interval data. My Z data is my ground surface elevation. So when setting my project dimensions do I have to take in account that my I-data may extend past the extents of my Z-data? For example, my project dimensions for Z(ground surface) are 6.85(min) to 11.1(max), but i have interval data that goes down to 20' below ground surface. Should i set my min Z to -20?

Thanks for the help. :D

post-528-1226517052_thumb.jpg

Share this post


Link to post
Share on other sites

Hi Will,

An Iso-Surface represents 1 value so it's all 1 color. We do contour the outer sides of the Iso-Surface when it intercepts the boundary of the model but unfortunately at this time we can't contour the interior sections in cut outs. For more interior definition you can use multiple Iso-Surfaces at different values (XIsoSurface) or use a Voxel model.

Mitch

Share this post


Link to post
Share on other sites

Will - regarding you question about project dimensions in the Z direction - the project dimensions define the extent of the model created, so unless you only want to model your shallower data for some reason, you should extend your project dimensions down to the bottom of your interval data.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×