Jump to content
RockWare Support Forum
Sign in to follow this  
Molly

RockWare GIS Link2 and Windows Vista 64

Recommended Posts

Have any users had problems loading the RockWare GIS Link 2 toolbar into ArcView 9.3 running under 64-bit Vista? Were there any tricks that needed to be done to get the DLL registered in Vista, and the toolbar visible in ArcMap?

We were not aware of any compatibility issues, but we have a user who can't get the GIS Link toolbar to appear.

Thanks,

Molly

RockWare Inc.

Share this post


Link to post
Share on other sites

The solution seems to involve the following steps:

1) Add the toolbars manually, as administrator:

a. Run C:\Program Files\ArcGIS\Bin\categories.exe as an administrator.

b. In the Component Category Manager window, scroll down to the ESRI MxCommandbars category, and expand it.

c. Click the Add Object button and browse for the GIS Link dll (c:\program files\rockware\rockware_gis_link\rockware_gis_link_2.dll).

d. Scroll down to the ESRI MxCommands category, and expand it.

e. Click the Add Object button and browse for the GIS Link's dll.

2) Now add the toolbars in ArcMap.

a. Start up ArcMap and select Tools / Customize.

b. On the Toolbars tab, scroll down and locate the RockWare GIS Link item, and insert a check-mark.

c. Click the Close button, and the toolbar should now be displayed.

! If the RockWare GIS Link item is not displayed in the Tools menu, try clicking Add from File, and browse to the rockware_gis_link_2.dll, path shown above.

!! If the RockWare GIS Link item is still not displayed in the tools menu, you'll need to run step 0 below, and then run steps 1 and 2 again.

0) Register the DLL manually, as administrator. (This step SHOULD be done by the GIS Link's installation program, particularly if you run the installation As Administrator. However, if ArcMap is not loading the toolbar, you should try this manually before running the above steps.)

a. Run C:\Windows\SysWOW64\cmd.exe as an administrator (right-click, choose Run as Administrator).

b. Register the DLL with command: regsvr32 c:\program files (x86)\rockware\rockware_gis_link\rockware_gis_link_2.dll.

Still no luck? Contact RockWare tech support with details.

Thanks to Anuja C at ESRI for all the help.

Molly

RockWare Inc

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×