Jump to content
RockWare Support Forum

Incorrect Z units in Stratigraphy Picker


Ian Madin
 Share

Recommended Posts

I am using UTM coordinates with meters for horizontal and feet for vertical in my borehole database. The borehole manager shows  that my stratigraphy and lithology  intervals are in feet, and I have entered those values as feet. However, when I use the stratigraphy picker, it converts the values in the table to meters, regardless of whether I check the convert units box in the 2D log design depth menu to feet or meters. The graphic display is correct in both cases. Do I have to convert new values by hand to enter them into the table correctly?

Link to comment
Share on other sites

Hi Ian,

 

Bear in mind that while you can enter your data with mixed units (e.g. meters X and Y, feet elevations and depths), RockWorks does require that you pick one unit for your output models and diagrams. This assures your volumes make sense, such as cubic meters versus cubic-feet-meters. And so that the diagrams and models scale nicely.

 

The input units will be displayed in the Borehole Manager's Location tab. The output units will be displayed in the Dimensions tab at the top of the program window.

 

In the Stratigraphy and Lithology picker programs, RockWorks will be using your output units for diagram generation. But I think you will find that, even if it is posting meters as you pick the contacts, when you close the picker and it posts the data back to the database, it will convert it back to your entered units (feet).

 

Be sure to make a backup of your database before running the Strat Picker, just in case. The program offers this automatically.

 

(I am working with RockWorks 2021.2.9.)

 

Molly
RockWare Support

Link to comment
Share on other sites

Yes. You can change the units you want for future model/diagram output by following the steps below. Note that this will not affect any existing maps, models, diagrams, 3D scenes, etc. You will need to regenerate those using the new output units if you want to append them to new diagrams.

  • Click on the Coordinates tab at the top of the program window.
  • Click the Reassign button.
  • Find the Output setting at the bottom of the window. Choose one of the two options (all feet or all meters).
  • Click Finish.
  • Confirm when prompted.
  • RockWorks will then set the output X, Y, Z units to feet or to meters, as you selected. It will not change any of your data, it will change only the units to be used for your output.
  • It will prompt you whether you want to re-scan the data for your new project dimensions at this time. You can choose Yes or No here. But BE SURE to rescan your project dimensions at some point, prior to model/diagram generation, for the new units. If you don't do this, RockWorks will output in the new units but using the wrong coordinate numbers. (As it scans your database it will convert the necessary values to comply with the desired output units.)

Molly

RockWare Support

 

mixed_units.png

Link to comment
Share on other sites

Hi Ian,

 

Because this has become data-specific, let's move this from the general forum to a tech support issue.

 

Please select the Borehole Manager's File | Backup Project menu option and send the zip file by email to support at rockware.com. We can take a look at the specific settings in the project to determine the problem. If the file is too large to email, send support an email requesting a link where you can upload it to our guest ftp site.

 

In the email please also specify the specific revision of the software (such as 2021.2.9) as displayed in the upper left corner of the main program window.

 

Thanks!
Molly 
RockWare Support

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...