Jump to content
RockWare Support Forum

Error: Division by zero in Lithology Type Table

Recommended Posts



I'm trying to import the USGS lithology .key files and .pat files for a project in Rockworks17.  I can import the USGSLithos2.key file, which populates the G-value, Keyword, Fill Percent, Density, and Show in Legend fields, and populates the Pattern field with a colour.  I then click on the pattern file of the first entry to bring up a new window, which yields a "division by zero" error (attached screenshot).  I am then unable to correctly map the .pat files to get the hatch patterns associated with the .key file.  I've tried clearing the Lithology Type Table, mapping the Stratigraphy Type Table, and rebooting the software to no success. Swapping to another project also yields the same error.


Any help would be greatly appreciated.




Screen Shot 2017-08-10 at 2.22.57 PM.png

Share this post

Link to post
Share on other sites

Hi Joel,


I can't duplicate the problem you are encountering. When I import the .key file, I can double-click on the pattern in the Lithology Types Table and specify the pattern and color.


I am running Windows on a PC and not a Mac as shown in your screenshot.


It looks like your .RwPat file may be corrupted or the program is unable to access the file on the X: drive on the network. 


You are welcome to send a copy of your .RwPat file in X:\Shared Program Data\RockWorks16\USGSLithos2\U...  to [email protected] and I will take a look.



Tom B

RockWare Inc


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...