Jump to content
RockWare Support Forum
Dave D

Quicksurf and AutoCAD 2016/2018

Recommended Posts

I have Quicksurf for AutoCAD 2013 (64 bit I believe) but my employer is planning to phase out 2013 and move to AutoCAD 2016 (or perhaps 2018). The Rockware Quicksurf page shows that the latest version is Quicksurf for AutoCAD 2013/2014 and makes no mention of later versions. My question is whether my current version of Quicksurf (2013/2014) will work with AutoCAD 2016/2018, or if there is a newer version than shown on the Rockware site.

Share this post

Link to post
Share on other sites

Hi Dave,


QuickSurf 2013 works with AutoCAD 2014 or older versions. The developer (Petrobyte) has ceased work on the program and no new versions are expected.  QuickSurf will not work AutoCAD 2016 and 2018.


Alternative programs include RockWorks and Surfer. These stand-alone programs run under Windows.


Tom B

RockWare Inc

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now