Jump to content
RockWare Support Forum
dsweetkind

Filter solid with grid - lost G-values

Recommended Posts

I am having trouble filtering a solid lithology model with a single grid. I am replacing G-values above the bounding grid with the null value -1e27. It appears that the solid model gets clipped correctly, but I lose my G-values in the resulting grid-filtered solid. If you look at the attached PDF, you will see that I am setting the color scheme to my lithology colorfill table, as correctly shown in the legend of the diagram, but the solid itself retains just a single G-value (appears to be a G-value of 1).

I must be making a simple mistake, but cannot figure out where. Any thoughts/advice appreciated.

Lithmodel_gridfiltered_01.pdf

Share this post


Link to post
Share on other sites

Isosurfaces function like contour "skins". By nature of the fact that you've set the minimum contour level to "1", the diagram is showing you all voxels with values 1 and greater, enclosed with the "1" value skin, which is set to red. If you insert a cutout into the isosurface (Edit | Add Cutout) then you can see inside the skin to the other colors (values) inside.

Instead, try using the other visualization method for solid models - Voxels. This type of display color-codes the visible voxels based on their value. The null voxels should still be hidden, and you can use the Voxel display options to filter low and/or high values from the display.

You might refer to these help topics:

Voxel displays: http://help.rockware.com/rockworks17/WebHelp/rp3d_data_sol_color.htm

Isosurface displays: http://help.rockware.com/rockworks17/WebHelp/rp3d_data_iso_color.htm

Hope this helps!

Molly Mayfield

RockWare Inc.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×