Jump to content
RockWare Support Forum
NickG

lith model that conforms to top of borehole elevations

Recommended Posts

Rock Works Community,

I am working in Rock Works 17 generating a lithological model from 35 boreholes from which I hope to take ~10-15 cross sections. My model generation is more or less working, but my issue is that I have not been able to figure out how to tell the model to conform to the surface profile established from the surface elevations of each borehole (interpolated linearly or otherwise). In other words, I want the model to define a non-flat ground surface from the known surface elevations of the boreholes and apply that to my cross sections (which I assume means it needs to be applied to my model as well). What is the easiest way to do this? Currently, my surface is shown as flat and above my borehole surface elevations (I think at the elevation of my overall domain's max Z value).

One rabbit hole I am looking into currently is generating a grid based map of my surface elevations and then running my model with a warp referenced to this grid. Is this a) a viable solution for what I am talking about and 'b) is there a better approach for what I am trying to do? Also, a brief account of the work flow for generating a grid-based map would be great, for so far I have not been able to figure out how to tell the grid generator to use my borehole elevations as input data.

I have attached an image of my cross section currently (with the flat top above my borehole elevations). I drew a crude red line on here to show what I am trying to achieve.

Thank you for your time.

ex cross section.png

post-19549-0-08077800-1468251775_thumb.png

Share this post


Link to post
Share on other sites

Hi Nick,

To make the model match your ground surface, choose the Borehole Manager menu Lithology | Section | Create New Model | Modeling Options | Superface | Automatic option.

LithologyCrossSectionClipToGroundSurface.png

I do not recommend warping the model to that grid unless you feel that the lithology layers should bend parallel to the ground surface.

To make a ground surface grid based on your boreholes, choose the Borehole Manager menu Map | Borehole Locations | Surface Contours | Create new grid.

Regards,

Tom B

RockWare Inc

post-527-0-13027000-1468257292_thumb.png

Share this post


Link to post
Share on other sites

I am having the same issue with my lithology model. I want the top of my model to look like the surface of the constraining layer, but instead it's just flat. I have made sure that the project dimensions are all the same and I've resampled the constraining grid layers, but the top of my lithology model is just flat. I've tried all the above tips, but still not having any luck. When I open the grid file, the topography is clear, but the same topography is not reflected in the lithology model. I'm not sure what's causing the issue. My project files are uploaded to https://www.rockware.com/upload/

Share this post


Link to post
Share on other sites

It seems that the smoothing is messing things up. It's probably a bug introduced recently in a fix, so in the meantime, turn off smoothing and you should be good.

Share this post


Link to post
Share on other sites

I am having the same issue with my lithology model. I want the top of my model to look like the surface of the constraining layer, but instead it's just flat. I have made sure that the project dimensions are all the same and I've resampled the constraining grid layers, but the top of my lithology model is just flat. I've tried all the above tips, but still not having any luck. When I open the grid file, the topography is clear, but the same topography is not reflected in the lithology model. I'm not sure what's causing the issue. My project files are uploaded to https://www.rockware.com/upload/

Josh,

It turns out that the "Replace Nulls" was causing your issue. Turn that off and you should be good. We will work on a fix for that in an upcoming version.

Brian

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×