Jump to content
RockWare Support Forum


Recommended Posts


i am creating mesh in petrasim using the polygonal method on an area of 30 x 24 km. i have around 50 wells towards the center and would like to achieve cells 10,000 m 2 around wells and 500,000 m 2 at the margins. when i try this i only achieve 738,808 m 2 near wells and 786,358 m 2 at the margins. is there a better way of achieving this ?.

Share this post

Link to post
Share on other sites

It would be helpful if we could take a look at your model - our tests show that the meshing tools get fairly close to the specified areas. For example I entered a value of 500 meters squared and the area of the cell intersecting the well was between 600 and 700. You can send your SIM file to Alison @ rockware.com.

Best Regards,


Share this post

Link to post
Share on other sites

After looking at the user's SIM file we realized that the program wasn't acting as expected because the wells in the SIM file were non-vertical. The program typically ignores non-vertical wells during meshing unless they are close to vertical within a threshold. The tolerance can be imagined as a vertical cylinder with the center axis going through the top point of the well. The cross-sectional area of the cylinder is the "Max area near wells" input.

The solution is to use the option to add additional refinement points during mesh generation.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now