Jump to content
RockWare Support Forum
jazzaus

Quicksurf in 2013 and Maximize Surface Operations

Recommended Posts

The Maximize Surface operations setting is not working. Whether it is turned on or off, surface operations are performed as if it is off.

I need to have it on.

Is there a system variable that I can set manually?

I am running Acad Map 3D 2013, QS 2013, Windows 7 64bit.

Joel

Share this post


Link to post
Share on other sites

Hi Joel,

The QuickSurf help states one possible cause of the problem:

Point to Point Operations

All operations between surfaces containing only points perform basic point to point arithmetic. Only points sharing exactly the same XY coordinate in both surfaces will have the mathematical operation performed. Points that do not have matching XY coordinates will not be operated upon

If this does not describe your situation, you are welcome to upload a ZIP file with your DWG and QSB to http://rockware.com/upload/ and I will take a look. Include a description of the steps you perform and your desired result.

Thanks,

Tom B
RockWare Inc

Share this post


Link to post
Share on other sites

Thanks Tom,

In the QS help:

-----------------------------------------------------------------------------------------------------------------

Maximize Surface Operations

Mathematical surface operations function by draping the elements of each surface onto the other, then processing the resulting pairs of Z values. This bi-directional draping is controlled by the Maximize Surface Operations checkbox. By default, this option is enabled, causing the bi-directional drape. It is a good idea to leave it enabled unless you have a specific reason to do otherwise.

For normal use, leave the Maximize surface operations button enabled.

If you deselect the Maximize Surface Operations checkbox, a mathematical surface operation drapes the first surface onto the second surface only. This means the resulting parts and the plan view geometry of the results < . > surface is based solely on the geometry of the first surface. If the second surface only has points, then point to point operations only are performed.

Consider the example of two surfaces overlying one another: one with 1000 points and a TIN, and the other with 100 points and a TIN. With Maximize disabled, the resulting surface will have different numbers of points depending upon which surface is the first surface in the surface operation. If the first surface is the 1000 point surface, the result will have 1000 points (assuming the surfaces overlap perfectly). If the first surface is the 100 point surface, the result will have 100 points (assuming the surfaces overlap perfectly). The plan geometry of the result reflects the first surface only. By contrast, if Maximize is enabled, the resulting surface will have 1100 points (assuming no points are coincident in XY).

-----------------------------------------------------------------------------------------------------------------

This is what I have experienced in my 20 years of use of QS. I have only noticed this recently with the 2013 release and have worked around the issue with external manipulations to get the surfaces that I want.

Maybe I am just missing something but if I have 2 non-coincident surfaces and I add (+) them in the surface operations dialog I expect to see all of the points in the resultant surface.

Can you verify that you experience the expected result?

Thanks,

Joel

Share this post


Link to post
Share on other sites

Tom,

Here are some screenshots of my dilemma. Please let me know if I am just missing something.

I uploaded them to the upload area:

Surf1.png

Surf2.png

operation.png

result.png

This is with Maximize Surface Ops on. It does not matter the order of surfaces specified. It produces the same result.

Thanks,

Joel

Share this post


Link to post
Share on other sites

Hi Joel,

We did not receive your PNG files or data. Please combine them into a ZIP file and upload with your QSB and DWB files and I'll take a look.

Thanks,

Tom B

RockWare Inc

Share this post


Link to post
Share on other sites

Hi Joel,

I got your files and found that the behavior is the same in QuickSurf 2013 under AutoCAD 2014, and in QuickSurf 2009 under AutoCAD 2009. When I add the L2 and L4 surfaces, the resulting surface is only present where both input surfaces are present.

I will look into draping as a way to produce a surface that is A+B where both are present, or just A or just B when only one surface is present.

Thanks,

Tom B

RockWare Inc

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×