Jump to content
RockWare Support Forum
Joel H

Problem adding minerals to thermo dbase

Recommended Posts

Hi Tom et al.,

I am trying to add a number of mineral phases to the thermo.com.v8.r6+ database, and I am consistently getting error messages for two of the phases I have entered. I was wondering if someone could take a look at the following entries to see if I am doing something incorrectly:

Sodic Sanidine type= Feldspar

formula= K0.51Na0.45Ca0.04Al1.04Si2.96O8

mole vol.= 100.75 cc mole wt.= 270.061 g

7 species in reaction

-4.1600 H+ 0.5100 K+ 0.0400 Ca++

0.4500 Na+ 1.0400 Al+++ 2.9600 SiO2(aq)

2.0800 H2O

500.0000 1.3900 500.0000 500.0000

500.0000 500.0000 500.0000 500.0000

TiMt type= Spinel

formula= Fe2.45Ti0.55O4

mole vol.= 45.25 cc mole wt.= 178.543 g

5 species in reaction

-5.8000 H+ 1.5500 Fe++ 0.5500 Ti(OH)4(aq)

1.8000 H2O 0.9000 Fe+++

500.0000 14.0200 500.0000 500.0000

500.0000 500.0000 500.0000 500.0000

As you can see, these are solid solutions. I am calculating log K's at 25C assuming ideal mixing after Gislason and Arnorsson (1993), Chemical Geology.

I've input 5 other solid solutions and had no problem, but I get the following error messages for these two phases when I try to load the modified database:

reaction mass imbalance for Sodic Sanidine = 1.02

Reaction = Sodic Sanidine + 4.16*H+ = .51*K+ + .04*Ca++ + .45*Na+ + 1.04*Al+++ + 2.96*SiO2(aq) + 2.08*H2O

reaction mass imbalance for TiMt = 48.6

Reaction = TiMt + 5.8*H+ = 1.55*Fe++ + .55*Ti(OH)4(aq) + .9*Fe+++ + 1.8*H2O

I'm guessing I've made a stupid math error somewhere when balancing my reactions, but I'll be darned if I can figure out where it is.

Any help is greatly appreciated! Thanks,

Joel

Share this post


Link to post
Share on other sites

Hi Joel:

'Reaction mass imbalance' errors usually refer to a problem with the molecular weight. I notice that your two problem entries have only have 3 digits after the decimal on the molecular weight - the GWB thermo databases require 4. Second, and more importantly, be sure that your molecular weight reflects the summation of the basis species in your reaction (multiplied by the stoichiometric coefficients), using the individual mole weights given in the Basis species section near the top of the database.

Let me know if that gets you there....

Regards,

Tom

Share this post


Link to post
Share on other sites

Hi Tom,

Ug. Yes that got me there. It was a calculation error on my molecular weights. That's what I get for not double-checking my formulas in Excel before input into the database. Sorry to have bugged you with such a mundane problem - I'm embarrassed to have posted this thread on the forum at all!

Thanks so much for your help,

Joel

Share this post


Link to post
Share on other sites

Hi Joel:

This happens to all of us. I actually appreciate you posting this. There are no mundane questions, and the greater user community benefits from seeing these problems worked out online.

Regards,

Tom

Share this post


Link to post
Share on other sites

×