Jump to content
RockWare Support Forum
mark

Stratigraphy (interpolated surface model)

Recommended Posts

I've used Stratigraphy>Section>Model(interpolated surface model) to create the attached cross-section. Layers 2 and 3 are only found in the 2 boreholes at the D' end of the section. Although I've entered a 0 thickness for the layers in the 6 other boreholes, a lens of each is generated between the boreholes. How can the lenses be eliminated?

post-2431-12741200643678_thumb.png

Share this post


Link to post
Share on other sites

Hi Mark,

First, you might try a different gridding algorithm - I've had luck with triangulation to be sure that layers don't thicken up. Be sure that Onlap is turned on. You might also turn off the Smoothing option in the Gridding Options. If this does not work, then you'll need to do some manual editing.

(1) First, write down the names of the "expected" (automatically-named) grid models. This will help you keep track of what is what. For example:

uppergreen_top.grd

uppergreen_base.grd -- same

upperyellow_top.grd _/

upperyellow_base.grd -- same

lowergreen_top.grd _/

lowergreen_base.grd -- same

loweryellow_top.grd _/

loweryellow_base.grd

(2) Create an isopach grid of lowergreen formation (Stratigraphy | Stratigraphic Thickness | 2D) being sure to turn on Save Grid Model to save the lowergreen_thickness.grd model.

(3) Edit the lowergreen_thickness.grd so that the nodes are zero where they should be zero. (Use the grid editor - Grid | Edit - or you can clip the grids with a polygon - Grid | Filters | Polygon Clip.)

(4) Add the edited lowergreen_thickness.grd to loweryellow_top.grd to generate a new version of lowergreen_top.grd. The zero-thickness areas of this isopach will force the top of the lower green to lie right on top of the lower yellow.

(5) Create an isopach grid of upperyellow formation, being sure to save the grid as upperyellow_thickness.grd.

(6) Edit the upperyellow_thickness.grd to zero out the nodes where they should be zero.

(7) Add the edited upperyellow_thickness.grd to lowergreen_top.grd, to generate a new and improved upperyellow_top.grd.

(8) Use Windows Explorer to make a copy of the new lowergreen_top.grd and rename it upperyellow_base.grd so that they are the same surface.

(9) Use Windows Explorer to make a copy of the new upperyellow_top and rename it uppergreen_base so that they are the same surface.

(10) Use Windows Explorer to make copies of ALL of your grid models and stash them somewhere just in case.

(11) Recreate the section with Interpolate Surfaces turned OFF. (This is important, so that it uses all these edited grids.)

Hope this helps

Molly Mayfield

RockWare Inc.

post-3-12742196239326_thumb.jpg

Share this post


Link to post
Share on other sites

Molly, thanks for taking the time to outline these steps. They worked. When I'm editing the grid models I used the Show Points tool. Is there a way to show the borehole names?

Share this post


Link to post
Share on other sites

No... in the grid editor the only labeling options involve the data values. (I'll add ID to the wish-list).

Re: plotting symbols and/or labels: Note that since the Grid Editor is in the Utilities portion of the program, you'll need to have borehole information listed in the Utilities datasheet to be able to plot the control point symbols and/or labels. You can use the Stratigraphy | Export | Stratigraphy -> ASCII XYZ File option to generate an XYZ list of the depths or elevations or (best, for your application) thickness for a selected unit. The resulting list can then be sent over to the Utilities using File | Transfer to Utilities Datagrid. Then, in the grid editor, open the GRD file representing the same unit whose data you just transferred. Click on the Points button at the top of the window. Along the left edge of the Point Plotting Options window, set the X (Easting) column to the data column "X", the Y (Northing) column to the data column "Y" and the Z(Elevation) column to "Z". Insert a check in Plot Symbols and choose the style. Insert a check in Plot Labels, and set content to Original Control Point Z Values. You should then get control point symbols and thickness labels overlaying the grid nodes.

post-3-12742904973055_thumb.jpg

Share this post


Link to post
Share on other sites

Hi, I'm working on a similar problem, and your solutions seem like they're going to work.

However, I can't figure out how to add my edited isopach grid corresponding to "Formation A" to the previous surface "Bedrock" grid in order

to save it as the new version of "Formation A".

Is this option in the Grid Editor?

Thanks!

Share this post


Link to post
Share on other sites

Hi Molly,

The procedure you outlined to manually edit isopachs for constructing new surfaces worked great, thanks! I now need to generate cross sections showing the stratigraphy I just edited.

When those sections are complete, I'll undoubtedly need to adjust some of the surfaces to reflect my interpretation of the stratigraphy between control points.

Is there a straightforward was to do so?

Thanks!

Share this post


Link to post
Share on other sites

After constructing and editing the surfaces as described above, RW will construct a box strat model using the edited surfaces, so I know it recognizes them. However, when I request a multipanel strat section, the output drawing is generated without stratigraphic information (output is a borelog section). How do I enable RW to use my surfaces for these sections?

Share this post


Link to post
Share on other sites

Hi Joe,

- Choose the Stratigraphy | Section | Modeled (Interpolated Surface Models) menu command to display the data from the stratigraphy GRD files. If you create your section with the Striplogs | Multi-log Section menu, only the logs are displayed.

- To edit a stratigraphy GRD file, use the Utilities Grid | Edit menu command.

If you just want to edit the cross-section, click in the middle of the polygon to select it, then right-click and choose Edit Vertices.

Thanks,

Tom B

RockWare Inc

Share this post


Link to post
Share on other sites

Hey Tom,

Thanks for the reply. I'm using the correct menu to generate the stratigraphic sections, the stratigraphy just is not being produced.

I just went through the stratigraphic picks to make sure the contacts were right. The software has them on file, they just are not being recognized when I call for a stratigraphic section.

Any ideas?

Share this post


Link to post
Share on other sites

Hi Joe,

I can't tell without seeing the files. You are welcome to backup the project to a ZIP file, add all the GRD files that you have created to the ZIP file and send the ZIP to me, tomb at rockware dot com. Larger files may be uploaded to http://rockware.com/upload/

Thanks,

Tom B

RockWare Inc

Share this post


Link to post
Share on other sites

Hi Joe,

I got your files and I see that you have the Truncate option turned on in the Stratigraphic Section menu. Turn this off to see the model.

Thanks,

Tom B

stratigraphicsectiontru.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×