Jump to content
RockWare Support Forum
Ozi

Comma instead of point

Recommended Posts

Hi there!!

I have tried to add images to the log in an Image Column. It works very fine, looks good. :rolleyes: But when I close the tab with a log, or whole LP, and then start it again, links in Bitmap column change from like C:\xyz.jpg to C:\xyz,jpg and therefore don't work. :( It's all the same if I insert picture as "Link to file" or "Imbed in LPT". I use "Imbed in LPT" as default, and it sounds logical that link is no more needed (as LP should imbed those images), but error apears anyway.

So, do you have any idea how to solve this?

Thank you, Ozi

Share this post


Link to post
Share on other sites

Hi Ozi,

I cannot duplicate the problem of the period changing to a comma on the Data tab in LogPlot7. However, after I compile the log and save the LPT, the reference in the Data tab is not used, so the LPT can be opened regardless of what is in the Data tab. If you need to compile the log again, change the comma in the file name back to a period.

It is possible that the change occurs due to non-US settings in Windows. If the problem continues, please report the version of Windows and any non-US settings, as well as the version of LogPlot that you are using. You are welcome to send your LDF or LDFX file, DAT file, and raster file and I will take a look.

Thanks,

Tom B

Share this post


Link to post
Share on other sites

Hi Ozi,

I think the error is occurring because of the way LogPlot displays your data file (.DAT) in the program window. When LogPlot launches, it looks at your Windows settings to determine the number format which is established (such as "," or "." for the decimal point). Then, when it opens a DAT file, it will display the file with the correct decimal character. Note that the data is always saved using U.S. number formats, but the display of the DAT file in the data window, of the LDFX file in the log design window, and of the compiled logs, should honor your Windows setup. What it seems to be doing is translating non-numeric entries as if they were numbers.

If you are able to re-enter the image file name using the dot character, and then compile the log and save the LPT file, reopening the LPT file at a later date should still work. Even if you choose Link rather than Embed.

We have sent this issue to the programming group and should have a solution shortly.

Thanks

Molly Mayfield

RockWare Inc

molly@rockware.com

Share this post


Link to post
Share on other sites

Hi there!!

Thank you, Molly and TomB, for quick reply!

Well, I was affraid that it was the US number format that's creating a problem. Not the first time - I had similar problems with decimal numbers in Interval-data tabs too. But there, it sometimes did happen, sometimes did not ?!? Anyway, I don't think that creating LPT files is a solution for me, cause I'm adding data all the time, as I get new chemical analysis data and so on. I guess I'll leave the bitmaps for the last. And, untill some solution comes along, I'll just have swich to US number format while working in LP or RW :-(

Thanks again for your help,

Ozi

Share this post


Link to post
Share on other sites

Hi!

Uh, I forgot to mention, I use latest version of LP (7.4.72.98), WinXP (SP3);

decimal symbol ",", digit grouping symbol ".", measurement system "Metric"...

Thanks, Ozi

Share this post


Link to post
Share on other sites

Bravoooo!! :D

Works perfectly!!! Thank you, that was really quick!

Ozi

P.S. Do you always fix LP problems so fast? I'll have to complain more often ;) !!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×