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A Guided Tour of AqQA 

About AqQA® 

Imagine you could keep the results of your chemical analyses in a 

spreadsheet developed especially for the purpose. A spreadsheet that 

knows how to convert units, check your analyses for internal consistency, 

graph your data in the ways you want it graphed, and so on. 

A spreadsheet like that exists, and it’s called AqQA. AqQA was written 

by water chemists, for water chemists. Best of all, it is not only powerful 

but easy to learn, so you can start using it in minutes. Just copy the data 

from your existing ordinary spreadsheets, paste it into AqQA, and you’re 

ready to go! 

To see what AqQA can do for you, take the guided tour below. 

Data Sheet 

When you start AqQA, you see an empty Data Sheet. Click on File → 

Open…, move to directory “My Documents\AqQA\Examples” and open 

file “Example1.aqq”. 

The example Data Sheet 

 

is arranged with samples in columns, and analytes – the things you 

measure – in rows. 

Sample

Analyte

Sample

Analyte
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You can flip an AqQA Data Sheet so the samples are in rows and 

analytes in columns by selecting View → Transpose Data Sheet. Click 

on this tab again to return to the original view. 

Tip: AqQA by default labels analytes by name (Sodium, Potassium, 

Dissolved Solids, …), but by clicking on View → Show Analyte 

Symbols you can view them by chemical symbol (Na, K, TDS, …). 

To include more samples or analytes in your Data Sheet, click on the 

“Add Sample” or “Add Analyte” button: 

 

You select analytes or samples by clicking on “handles”, marked in the 

Data Sheet by small triangles. You can select the values associated with 

an analyte using a separate set of handles, next to the “Unit” column. 

Give it a try! 

Tip: To rearrange rows or columns, select one or more, hold down the 

Alt key, and drag them to the desired location. 

Entering Data 

To see how to enter your own data into an AqQA Data Sheet, begin by 

selecting File → New. Add to the Data Sheet whatever analytes you 

need, and delete any you don’t need. 

Tip: To delete analytes, select one or more and click on the  button. 

To delete samples you have selected, click on the  button. 

When you click on the “Add Analyte” button, you can pick from among 

a number of predefined choices in various categories, such as “Inorganic 

Analytes”, “Organic Analytes”, and so on: 

Add a 

sample

Add an analyte

Select analyte(s) Select sample(s)

Select values
Add a 

sample

Add an analyte

Select analyte(s) Select sample(s)

Select values
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A number of commonly encountered data fields (Date, pH, 

Temperature, …) can be found in the “General” category. 

Tip: If you don’t find an analyte you need among the predefined choices, 

you can easily define your own by clicking on Analytes → New 

Analyte…. 

To make your work easier, rearrange the analytes (select, hold down the 

Alt key, and drag) so they appear in the same order as in your data. 

Tip: You can add a number of analytes in a single step by clicking on 

Analytes → Add Analytes…. 

Set units for the various analytes, as necessary: right click in the unit 

field and choose the desired units from under Change Units, or select 

Change Units under Analytes on the menubar. 

 

… lets you 

choose 

analytes from 

various 

categories

“Add Analytes” 

button …

… lets you 

choose 

analytes from 

various 

categories

“Add Analytes” 

button …

Right click to 

change units

Right click to 

change units
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Tip: You can change the units for more than one analyte in one step. 

Simply select any number of analytes and right-click on the unit field. 

 

Tip: Analyses are sometimes reported in elemental equivalents. For 

example, sulfate might be reported as “SO4 (as S)”, bicarbonate as 

“HCO3 (as C)”, and so on. In this case, right click on the unit of such an 

analyte and select Convert to Elemental Equivalents. 

You can now enter your data into the Data Sheet as you would in an 

ordinary spreadsheet. 

Tip: If you have an analysis below the detection limit, you can enter a 

field such as “<0.01”. AqQA knows what this means. If the analysis 

reports an analyte was not detected, enter a string such as “n/d” or “--”. 

For missing data, enter a non-numeric string, or simply leave the entry 

blank. 

You of course can type data into the Data Sheet by hand, or paste the 

values into cells one-by-one. But it’s far easier to copy them from an 

ordinary spreadsheet or other document as a block and paste them all at 

once into the AqQA Data Sheet. 

Making sure the analytes appear in the same order as in your spreadsheet, 

copy the data block, click on the top, leftmost cell in the AqQA Data 

Sheet, and select Edit → Paste, or touch ctrl+V. 

Tip: If there are more samples in a data block you are pasting than in 

your AqQA Data Sheet, AqQA will make room automatically. 

 

Tip: If the data arranged in your spreadsheet in columns fall in rows in 

your AqQA Data Sheet, or vice-versa, you can transpose the Data Sheet, 

or simply select Edit → Paste Special → Paste Transposed. 

If you would prefer to import a file, rather than copying and pasting, you 

can use the File →  Import Data menu to import a CSV file.  The 

program allows you to map columns to analytes in the AqQA library, so 

that you do not have to set up a template to match your existing 

datasheet.  CSV files can be easily exported using most spreadsheet or 

database programs. 

Tip: You can flag data in an AqQA Data Sheet that fall outside 

regulatory guidelines. Select Samples → Check Regulatory Limits, or 

click on . Violations on the Data Sheet are flagged in red. 

Working With Data 
Once you have entered your chemical analyses in the Data Sheet, AqQA 

can tell you lots of useful information. 

Click on File → Open… and load file “Example2.aqq” from directory 

“My Documents\AqQA\Examples”. To see AqQA’s analysis of one of 



     

     

 

A User's Guide to AqQA® A Guided Tour of AqQA • 5 

     

     

 

the samples in the Data Sheet, select the sample by clicking on its handle 

and then click on the  tab. This moves you to the Data 

Analysis pane, which looks like 

 

There are a number of categories in the Data Analysis pane. To open a 

category, click on the corresponding bar. A second click on the bar closes 

the category. Clicking on the  symbol gives more information about 

the category. 

Tip: You can view the data analysis for the previous or next sample in 

your Data Sheet by clicking on the  and  buttons to the left and 

right of the top bar in the Data Analysis pane. 

The top category, Fluid Properties,  identifies the water type, dissolved 

solids content, density, temperature-corrected conductivity, and hardness, 

as measured or calculated by AqQA. 

The next category, Internal Consistency, reports the results of a number 

of Quality Assurance tests from the American Water Works Association 

“Standard Methods” reference. For example, AqQA checks that anions 

and cations balance electrically, that TDS and conductivity 

measurements are consistent with the reported fluid composition, and so 

on. 

The Carbonate Equilibria category tells the speciation of carbonate in 

solution, carbonate concentration calculated from measured titration 

alkalinity and vice-versa, the fluid’s calculated saturation state with 

Click on any 

bar to expand 

or close up a 

category

Click here 

for more 

information

Click on any 

bar to expand 

or close up a 

category

Click here 

for more 

information
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respect to the calcium carbonate minerals calcite and aragonite, and the 

calculated partial pressure of carbon dioxide. 

The Irrigation Waters category shows the irrigation properties of a 

sample, and the Geothermometry category shows the results of applying 

chemical geothermometers to the samples, assuming they are geothermal 

waters. 

Finally, the sample’s analysis is displayed in a broad range of units, from 

mg/kg to molal and molar. 

Tip: You can print results in the Data Analysis pane: open the categories 

you want printed and click on File → Print… 

Graphing Data 
AqQA can display the data in your Data Sheet on a number of the types 

of plots most commonly used by water chemists. 

To try your hand at making a graph, make sure that you have file 

“Example2.aqq” open. If not, click on File → Open… and select the file 

from directory “My Documents\AqQA\Examples”. 

On the Data Sheet, select the row for Iron. Hold down the ctrl key and 

select the row for Manganese. Click on  and select Time Series 

Plot. The graph appears in AqQA as a new pane. 

The result should look like: 

 

You can select the analytes and samples to appear in the graph on the 

control panel to the right of the plot. Right clicking on the pane’s tab, 

along the bottom of the AqQA window, lets you change the plot to a 

different type, or delete it. 

To change or 

delete a graph, 

right-click on 

its tab

Click here to 

alter the graph’s 

appearance

Select 

analytes …

… and 

samples to 

graphTo change or 

delete a graph, 

right-click on 

its tab

Click here to 

alter the graph’s 

appearance

Select 

analytes …

… and 

samples to 

graph
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Tip: You can alter the appearance of a graph by clicking on the 

Advanced Options… button on the graph pane. 

You can copy the graph (Edit → Copy) and paste it into another 

program, such as an illustration program like Adobe® Illustrator® or 

Microsoft® PowePoint®, or a word processing program like Microsoft® 

Word®. 

Tip: Once you have pasted a graph into an illustration program, you can 

edit its appearance and content. To do so, select the graphic and ungroup 

the picture elements (you may need to ungroup them twice). 

You can also send it to a printer by clicking on File → Print. 

Tip: In addition to copying a graph to the clipboard, you can save it in a 

file in one of several formats: as a Windows® EMF file, an Encapsulated 

PostScript® (EPS) file, or a bitmap. Select File → Save Image As… and 

select the format from the “Save as type” dropdown menu. 

 

Tip: Select a linear or logarithmic vertical axis for a Series or Time 

Series plot by unchecking or checking the box labeled “Log Scale” on 

the Advanced Options… →  dialog or  dialog. 

AqQA can display your data on a broad variety of graphs and diagrams: 

simply choose a diagram type from the  pulldown. 

In addition to Time Series plots, AqQA can produce the following types 

of diagrams: 

Series Diagrams. 
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Cross Plots, in linear and logarithmic coordinates. 

 

Ternary diagrams. 
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Piper diagrams. 

 

Durov diagrams. 

 

20%

20
%

20%

40%

40
%

40%

60%

60
%

60%

80%

80
%

80%

M
g

Ca

20%

20%

20
%

40%

40%

40
%

60%

60%

60
%

80%

80%

80
%

S
O

4

Cl
S

O
4
 +

 C
l C

a + M
g

N
a
 +

 K

C
O

3
 +

 H
C

O
3

80
%

80%

60
%

60%

40
%

40%

20
%

20%

O O

O

B B

B

B

B

B

H
H

H

C

C

C

J

J

J

E

E

E

D

D

D

L L

L

K
K

K

O

O

O

P

P

P

I
I

I

H

H

H

J
J

J

E E

E

I
I

I

1
0
0
%

 M
g

Na + K80%

50%

20%

Ca
80%

50%

20%

100% SO4

C
l

80%

50%

20%

H
C

O
3
 +

 C
O

3

80
%

50
%

20
%

1
0
0
0

1
2
0
0

1
4
0
0

1
6
0
0

1
8
0
0

2
0
0
0

6.80

6.90

7.00

TDS (mg/L)

pH

O

O O O

O

B

B B B

B

B

B B B

B

H

H H H

H

C

C C C

C

J

J J J

J

E

E E E

E

D

D D D

D

L

L L L

L

K

K K K

K

O

O O O

O

P

P P P

P

I

I I I

I

H

H H H

H

J

J J J

J

E

E E E

E

I

I I I

I

Legend

O P3-212

B P3-213

B P3-214

H P3-215

C P3-216

J P3-217

E P3-218

D P3-219

L P3-220

K P3-222

O P3-227

P P3-228

I P3-229

H P3-230

J P3-232

E P3-233

I P3-234



     

     

 

10 • A Guided Tour of AqQA A User's Guide to AqQA®  

     

     

 

Schoeller diagrams. 

 

Stiff diagrams. 

 

Radial diagrams. 
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Ion balance diagrams. 

 

Pie charts. 

 

Replicates, Standards, and Mixing 
AqQA can check replicate analyses, compare analyses to a standard, and 

figure the compositions of sample mixtures. 

Replicate analyses are splits of the same sample that have been analyzed 

more than once, whether by the same or different labs. The analyses, 

therefore, should agree to within a small margin of error. 

To see how this feature works, load (File → Open…) file 

“Replicates.aqq” from directory “My Documents\AqQA\Examples”. 

Select samples PCC-2, PCC-2a, and PCC-2b: click on the handle for 

PCC-2, then hold down the shift key and click on the handle for PCC-2b. 

Now, click on the  button on the toolbar. 

A new display appears at the right side of the AqQA Data Sheet, or along 

the bottom if you have transposed it. 
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The display shows the coefficient of variation for each analyte, and 

whether this value falls within a certain tolerance. Small coefficients of 

variation indicate good agreement among the replicates. The tolerance, 

by default, is ±5, but you can set it to another value by clicking on 

Samples → Set Replicate Tolerance…. 

A standard is a sample of well-known composition, one that was 

prepared synthetically, or whose composition has already been analyzed 

precisely. Enter the known composition as a sample in the Data Sheet 

and click on Samples → Designate As Standard, or the  button. 

Then select an analysis of the standard on the Data Sheet and click on 

Samples → Compare To Standard, or the  button. The display at 

the right or bottom of the Data Sheet shows the error in the analysis, 

relative to the standard. Set the tolerance for the comparison, by default 

±10, clicking on Samples → Set Standard Tolerance…. 

To find the composition of a mixture of two or more samples, select two 

or more samples and click on the  button on the toolbar. The 

composition of the mixed fluid appears to the right or bottom of the Data 

Sheet.  
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What’s New in AqQA 2.0 

64-bit 
AqQA has been updated to run as a 64-bit application. Its interface and 

functionality remain largely consistent with AqQA 1.5, with a few 

additional features introduced. 

CSV Data Import 
The new File | Import Data menu allows users to import data from a 

CSV file, typically created in Excel and exported to CSV format. In this 

format, samples must be organized by rows, with the Sample ID listed in 

the first column. 
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The CSV importer allows users to map each column to an 

“analyte” in the AqQA database by following these steps: 

1. Select the column of data to map in the panel on the left.  

2. Choose a Category and Analyte from the drop-down lists.  

3. Click the Assign button.  

4. After assigning analytes to all desired columns, click OK 

to complete the import. 

 

New Graphic Exports 
The File | Save As Image menu now includes options to export images 

in both PNG and JPG formats. 
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New Stiff Diagram Layout Options 
Stiff diagrams now offer flexible layout options, allowing the anions and 

cations to be moved up or down relative to one another. 

 

Also, more than one Stiff Diagram can now be plotted on a single page. 
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The Data Sheet 

About the Data Sheet 
The AqQA® Data Sheet is a special spreadsheet that holds your chemical 

data. The data is typically composed of the values measured for various 

analytes, for a number of samples. 

You can enter data into a Data Sheet and manipulate it, as described 

below. 

Creating a New Data Sheet 

To create a new AqQA Data Sheet, select File → New, or touch ctrl+N. 

An empty Data Sheet, containing a number of analytes, but no data, 

appears. 

The appearance of new Data Sheets is specified by a template. You can   

tgcreate your own template so new Data Sheets contain the analytes you 

need, in your choice of units, and ordered as you desire. For more 

information, see Template for New Data Sheets in the Tapping 
AqQA’s Power chapter of this guide. 

Opening an Existing Data Sheet 
AqQA files end with the extension “.aqq”. These files contain the data 

entered in the Data Sheet, as well as any graphs produced and the 

program’s current configuration. 

You can open an existing Data Sheet by clicking on File → Open… and 

selecting a “.aqq” file, either one that you have previously saved or an 

example file installed with the AqQA package. A number of sample files 

are installed in the “Examples” directory within the My 

Documents\AqQA directory. 

Layout of the Data Sheet 
An AqQA Data Sheet contains the values measured for various analytes 

(Na+, Ca2+, HCO3
−, and so on) for any number of samples that have been 

analyzed. Each piece of information about a sample is considered an 

analyte, even sample ID, location, sampling date, and so on. 

By default, each analyte occupies a row in the Data Sheet, and the 

samples fall in columns. You can reverse this arrangement, so analytes 

fall in columns and the samples occupy rows, by clicking on Edit → 
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Transpose Data Sheet. To flip the Data Sheet back to its original 

arrangement, click on this tab a second time. 

You can rearrange the order of analytes or symbols on the Data Sheet, as 

described below under Reordering Rows and Columns. 

Selecting Rows and Columns 
To select a row or column, click on the marker to the left of a row, or the 

top of a column. The marker for a row or column appears as a small 

triangle. Analytes have two markers, one for selecting the entire analyte, 

and one for selecting only the analyte’s data values. 

You can select a range of rows or columns by holding down the left 

mouse button on the marker at the beginning of the range, then dragging 

the mouse to the marker at the end of the range. Alternatively, select the 

beginning of the range, then hold down the shift button and click on the 

marker for the end of the range. 

To select a series of rows or columns that are not necessarily contiguous 

on the Data Sheet, select the first row or column, then hold down the ctrl 

key and select subsequent rows or columns. 

By clicking on one of the small blue squares at the top or left of the Data 

Sheet, you can select either the entire sheet, or all of the data values on 

the sheet. 

Reordering Rows and Columns 
You can easily rearrange the rows and columns of samples and analytes 

in your Data Sheet. To do so, first select a row or column, or a range of 

rows and columns, as described under Selecting Rows and 
Columns. Then, holding down the alt key, press the left mouse button, 

drag the selection to its new position, and release the mouse button. 

Adding Samples and Analytes 
To include more samples or analytes in your Data Sheet, select on 

Samples → Add Sample, or Analytes → Add Analyte, or simply click 

on the  or  buttons on the toolbar. To add several analytes at once, 

select Analytes → Add Analytes…, which opens a dialog box for this 

purpose. 

When you add an analyte, you choose from among the large number that 

AqQA knows about. These are arranged in categories: inorganics, 

organics, biological assays, radioactivity, isotopes, and a general 

category that includes things like pH, temperature, date, and sample 

location. 

If you don’t find the analyte you need, you can quickly define your own. 

Select Analytes → New Analyte…, or New Analyte… from the  
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dropdown menu. For more information about defining analytes, see the 

Analytes chapter of the guide. 

Deleting Samples and Analytes 
To delete analytes or samples, select one or more and click on Analytes 

→ Delete, or Samples → Delete. Alternatively, select an analyte and 

click on the  button, or a sample and click on . 

Using Analyte Symbols 
Analytes are labeled with names such as Sodium, Calcium, and 

Bicarbonate. If you prefer, you can view them labeled with the 

corresponding chemical symbols, such as Na+, Ca2+, HCO3
−. Simply 

click on View → Show Analyte Symbols. A second click on this tab 

returns to labeling analytes by name. 

Data Cells 
Each cell in the data sheet contains one of several types of information: 

1. A numerical value, such as the concentration of a species. 

2. A character string. 

3. A date or a time. 

Numerical values are, most commonly, simply a number. You can, 

however, indicate a lack of data with a character string, such as “n/d” or 

“Not analyzed”, or just leaving the cell empty. 

If an analysis falls below the detection limit for a species, enter the 

detection limit preceded by a “<”. For example, “<0.01”. 

Character strings, such as you might enter for the “Sample ID”, contain 

any combination of characters, and can be of any length. 

You can enter dates in a variety of formats: “Sep 21, 2003”, 9/21/03”, 

“September 23”, and so on. AqQA will interpret your input and cast it in 

your local format (e.g., mm/dd/yy in the U.S.). Similarly, enter time as 

“2:20 PM” or “14:20”. Append seconds, if you wish: 2:20:30 PM”. 

To change the width of the data cells (i.e., the column width), drag the 

dividing line between columns to the left or right. This changes the width 

of all the data columns in the Data Sheet. 

Entering Data 
To enter data into an AqQA Data Sheet, you can of course type it in from 

the keyboard, or paste it into the cells in the Data Sheet, one by one. 

It is generally more expedient, however, to copy all of the values as a 

block from a source file, such as a table in a word processing document, 

or a spreadsheet. To do so, set up your AqQA Data Sheet so that it 
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contains the same analytes as the source file, in the same order (see 

Adding Samples and Analytes above, and Reordering Rows and 
Columns). You don’t necessarily need to add samples: AqQA will add 

columns (or rows) to accommodate the data you paste. 

Now, select the data block from the source document and copy it to the 

clipboard. Move to AqQA, click on the top, leftmost data cell, and select 

Edit → Paste. If the source data is arranged in the opposite sense as your 

Data Sheet (the samples are in rows instead of columns, or vice-versa), 

transpose the Data Sheet (View → Transpose Data Sheet), or select 

Edit → Paste Special → Paste Transposed. 

Changing Units 
You can change the units of analytes on the Data Sheet at any time. To 

do so, select one or more analytes, then click on Analytes → Change 

Units. Alternatively, right click and choose a new unit from the options 

under Change Units. If you have entered numerical data for the analyte 

(or analytes), you will be given the option of converting the values to the 

new unit. 

Some unit conversions require that the program be able to estimate 

values for the fluid’s density, dissolved solids content, or both. If you 

have entered values for the Density or Dissolved Solids analytes, AqQA 

will use these values directly when converting units. 

If you have not specified this data for a sample, AqQA will calculate 

working values for density and dissolved solids from the chemical 

analysis provided. It is best, therefore, to enter the complete analysis for a 

sample before converting units, so the AqQA can estimate density and 

dissolved solids as accurately as possible. 

AqQA estimates density and dissolved solids using the methods 

described in the Data Analysis section of the User’s Guide, assuming a 

temperature of 20°C, if none is specified. AqQA can estimate density 

over only the temperature range 0°C –100°C; outside this range, it 

assumes a value of 1.0 g/cm3, which can be quite inaccurate and lead to 

erroneous unit conversions. 

Using Elemental Equivalents 
You may find that some of your analytical results are reported as 

elemental equivalents. For example, sulfate might be reported as “SO4 

(as S)”, bicarbonate as “HCO3 (as C)”, and so on. 

In this case, select the analyte or analytes in question and click on 

Analytes → Convert to Elemental Equivalents. Alternatively, select 

the analyte(s), then right click on your selection and choose Convert to 

Elemental Equivalents. 

To return to the default setting, select Analytes → Convert to Species, 

or select the Convert to Species option when you right-click. 
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Notes and Comments 
When you construct a Data Sheet, you may want to save certain notes 

and comments, such as a site’s location, who conducted the sampling, 

what laboratory analyzed the samples, and so on. 

To do so, select File → Notes and Comments… and type the 

information into the box that appears. This information will be saved 

with your AqQA document; you may access it and alter it at any time. 

Flagging Data Outside Regulatory Limits 
You can highlight on the Data Sheet concentrations in excess of an 

analyte’s regulatory limit. Select Samples → Check Regulatory Limits. 

Concentrations above the limit now appear highlighted in a red font. 

Select the tab a second time to disable the option. Touching ctrl+L also 

toggles the option. 

AqQA can maintain a regulatory limit for each analyte. The analyte 

library contains default limits based on U.S. water quality standards at 

the time of compilation, but you should of course verify these against 

standards as implemented locally. You can easily change the limit carried 

for an analyte, as described in the Analytes chapter of this guide. 

Importing Data 
You may wish to import a spreadsheet directly into the AqQA Data 

Sheet. To do this, first create a spreadsheet that includes a column 

labeled Sample ID in the first column (furthest to the left). 

To import a CSV file, select File → Import Data, and then choose your 

CSV file when prompted. 

The program will display all columns in the CSV file, except for the 

required Sample ID column. For each column, select the appropriate 

analyte and click the Assign button. Once all columns have been mapped 

correctly, click OK to complete the import. 
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Saving Data 
Before you exit AqQA, you will probably want to save your workspace, 

which includes the data in your Data Sheet, any graphs you have created, 

and so on, in a .aqq file. 

To save your workspace, select File → Save, or click on the  button on 

the AqQA toolbar. 

To save your workspace as a .aqq file under a different name, select File 

→ Save As… and specify the file’s new name. 

You may also want to save the data in the Data Sheet as a file that can be 

read by other applications, such as Microsoft® Excel®. For information 

on saving data in this way, see the next section, Exporting Data to 
Other Software. 

 

Exporting Data to Other Software 
When AqQA saves a .aqq file, it does so in a special format that includes 

all of the information about your AqQA session, such as the current 

option settings and the plots you have created. In this way, you can 

resume working where you left off. 

You may wish, however, to save the data in your Data Sheet in a format 

that you can read from programs such as Excel, or with a text editor. To 

do so, you create a text file in which the data cells are delimited with a 

special character, such as a comma or tab. 

Select File → Export Data… and on the resulting dialog box choose a 

character (e.g., comma or tab) to serve as the column separator. On this 
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box, you can also set details of how you want the data saved and what 

data you want included in the file. 

Printing the Data Sheet 

You can print the contents of the Data Sheet by selecting File → 

Print…. To control the appearance of the printed page, such how to scale 

the Data Sheet to the page, select File → Print Setup…. 

You can check what the printed Data Sheet will look like before you 

print it be selecting File → Print Preview. If you wish to continue, select 

the Print… button. To return to the Data Sheet, select the Close button. 
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Analytes 

About Analytes 
Analytes are the various measurements or properties of a sample that 

AqQA® can store, use, and display. Analytes include sodium, TCE, 

temperature, and so on. 

Analytes in AqQA fall into six categories. 

1. Inorganic Analytes – calcium, sulfate, and so on. 

2. Organic Analytes – tricholorethylene, vinyl chloride, etc. 

3. Biological Assays –  coliform bacteria, viruses, etc. 

4. Radioactivity –  particles,  particles, etc. 

5. Isotopes – 18O, 13C, and so on. 

6. General – temperature, pH, etc. 

AqQA comes with a set or “library” of predefined analytes, each of 

which has a set of properties that you can alter, if you wish. You can also 

readily define your own analytes to meet your needs. 

Analyte Properties 
Each analyte has associated with it a set of properties that define how 

AqQA treats it. Depending on category, the analyte properties may 

include: 

• Name. A label, such as “Sodium” or “Dissolved Solids”, for 

referring to the analyte. 

• Symbol. An optional symbol, such as “Na” or “TDS”, for 

referring to the analyte. 

• Dimension. The type of unit, such as “concentration”, “density”, 

or “distance”, used to measure the analyte. 

• Display Unit. The unit, such as “mg/kg”, “g/cm3”, or “cm”, used 

by default to represent the analyte. 

• Mole Weight. The molecular weight of the analyte, if it is a 

chemical species. 

• Equivalent Element. An element sometimes used to represent an 

analyte. The concentration of carbonate, for example, is 
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sometimes represented in terms of elemental carbon as “mg/kg 

as C”; sulfate in terms of sulfur as “mg/kg as S”. 

• Elemental Atoms Per Molecule. If the analyte is a species that 

has an equivalent element, this is the number of times the 

element appears in the species’ formula. 

• Ionic Charge. The electrical charge on the species, if the analyte 

is a species. 

• Conductivity Factor mho/cm per meq/L. The numerical factor 

used with the analyte’s concentration to calculate electrical 

conductivity, according to Standard Method 2510-A. 

• Minimum Acceptable Limit Value. A regulatory or other limit 

on the least acceptable value for the analyte. 

• Minimum Acceptable Limit Units. The unit corresponding to 

this value. 

• Maximum Acceptable Limit Value. A regulatory or other limit 

on the greatest acceptable value for the analyte. 

• Maximum Acceptable Limit Units. The unit corresponding to 

this value. 

• Regulation. The regulatory source, such as a USEPA MCL, or 

Maximum Contaminant Level, for above. 

• Description. An optional note describing the analyte. 

• Source. An optional note giving the data source. 

• AqQA Uses As. If the program recognizes the analyte as having 

a special role in its calculations, that role is noted here. 

• Significant Digits. The number of digits used to display a value 

for the analyte. 

• Conserved. A flag indicating whether the analyte is conserved 

during mixing, used in AqQA’s “mix” feature. 

Changing the Properties of an Analyte 
You can change the properties of any analyte on your Data Sheet. You 

might, for example, want to change the acceptable limit for lead to a new 

value. 

To change an analyte’s properties, click on Analytes → Analyte 

Properties and select the analyte category corresponding to the analyte 

in question. Alter any or all of the properties for the analyte, then click on 

the Data Sheet pane to return to your data. 

When you change properties in this way, you alter them only within the 

current AqQA document. To alter properties in future documents, see 

Editing the Analyte Library. 
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Creating a New Analyte 
You can create your own analyte to reflect, for example, a species not 

included in the analyte library. Click on Analytes → New Analyte… 

and in the dialog box that appears select the appropriate category 

(“Inorganic Analytes”, “Organic Analytes”, etc.). If no other category 

seems applicable, choose “General”. 

Fill in the properties requested on the dialog box and click “OK”. The 

new analyte appears in your Data Sheet, along with AqQA’s pre-defined 

analytes. 

You can change the analyte’s properties, as well as define those not 

included in the dialog box, at any time by clicking on Analytes → 

Analyte Properties. 

Analyte Libraries 
AqQA comes with a library of analytes known to it, and analytes’ 

properties. The analyte library, named “library.aqq”, is available in 

C:\ProgramData\RockWare\AqQA. 

You can easily define your own library, generally by modifying or 

adding to the analytes in library.aqq, as discussed in the next section, 

Editing the Analyte Library. You can save your custom library under 

any name, in any directory. 

To tell AqQA to use a custom library instead of the default, select on File 

→ Preferences and click on the Browse button next to the Import 

Standard Analytes From field. From now on, when you add analytes to 

your Data Sheet, or create a new AqQA file, AqQA will take analytes 

and their properties from your custom library. 

Editing the Analyte Library 
To create a custom analyte library, open the library as you would any 

AqQA file, by clicking on File → Open…. It’s a good idea to save a 

copy of the default library that comes with AqQA under a different name, 

and modify the copy. As described in the previous section, Analyte 

Libraries, use the File → Preferences dialog to tell AqQA to use the 

custom instead of default library. 

Once you have opened the custom library, select the category 

(inorganics, organics, and so on) you would like to edit from Analytes → 

Analyte Properties. Edit the analytes as you would any AqQA Data 

Sheet. You can add analytes, delete them, and alter analyte properties. 

Continue by editing the analytes in the other categories, as desired.When 

you are done editing the library, save it as you would any other AqQA 

file, by clicking on File → Save or File → Save As…. 
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Updating AqQA Files 
Once you have changed analyte properties in the analyte library, or added 

analytes to the library, your changes will appear in the new AqQA 

documents you create, provided you have set AqQA to use the new 

library (on the File → Preferences dialog). 

Your exisiting .aqq files, however, will be unaffected by changes to the 

library, unless you update them. For example, if you change the 

regulatory limit for an analyte in the standard library, the new limit will 

be reflected in new .aqq files you create, but not exisiting files, unless 

you update them. 

If you have modified any of the analyte definitions in the default 

template (“default.aqq”) or any templates you have created (see 

Template for New Data Sheets), furthermore, you will need to 

update these files. 

To update an AqQA document, open it (File → Open…) and click on 

Analytes → Update Analytes…. The resulting dialog box allows you to 

reconcile analyte properties in the current document with an analyte 

library, or with the analyte properties in any other AqQA document.  

The dialog box will list the analyte properties that differ between your 

document and the library. To accept the updates, click on Select All¸or 

select only those you wish to apply, and then Apply Selected. Click on 

Done to return to working with the revised AqQA document. 
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Data Analysis 

About Data Analysis 
The Data Analysis pane displays useful information about a water sample 

from the Data Sheet. The sheet contains a number of categories of 

information, with horizontal bars for each category labeled “Fluid 

Properties”, “Internal Consistency”, and so on. 

To see the information under a given category, click on the bar. Clicking 

on the bar a second time closes the category, and clicking on the  

button displays helpful information about the category. 

The label for the sample in question is shown at the top of the pane. Also 

there are two arrow buttons that allow you to scan forward and backward 

through the samples on the Data Sheet. 

In performing the calculations on this pane, AqQA® assumes conditions 

of 20°C, unless a temperature has been entered for the sample on the 

Data Sheet. In no density is reported, AqQA will estimate an appropriate 

value, as described below. AqQA can estimate density over only the 

temperature range 0°C –100°C; outside this range, it assumes a value of 

1.0 g/cm3, which can be quite erroneous. Finally, if no value is reported 

for dissolved solids, AqQA calculates one from the sample’s chemical 

analysis, as described below. 

In this chapter, an “AWWA Standard Method” refers to a method 

described in the cited section of the AWWA “Standard Methods” 

volume. The complete reference to this volume is: 

Clesceri, L.S., A.E. Grrenberg, and A.D. Eaton, 1998, Standard Methods 

for the Examination of Water and Wastewater, 20th ed., American Public 

Health Association (Washington), American Water Works Association 

(Denver), and Water Environment Federation (Alexandria, VA). 

Fluid Properties 
The Fluid Properties category of the Data Analysis pane reports various 

properties of the water sample. 

Water Type 

The water type – e.g., Ca-HCO3 or Na-SO4 – is determined by finding 

the predominant inorganic cation and anion, figured on the basis of 

electrical equivalents. 
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In determining water type, AqQA accounts whenever possible for the 

carbonate speciation in solution, using the sum in electrical equivalents 

of the CO3
− and HCO3

− concentrations to represent carbonate. If 

carbonate is the dominant anion by this criterion, AqQA states the water 

type in terms of whichever of the two species is present in larger 

equivalent concentration (e.g., Ca-HCO3 or Na-CO3). 

AqQA also calculates, where pH is given, the free ion concentrations of 

H+ and OH−, and accounts for these species when assigning a water type. 

An acidic solution might be typed H-SO4, for example, or an alkaline 

water, Ca-OH. 

Dissolved Solids 

The program displays the water’s calculated dissolved solids content, 

along with the measured value, if supplied on the Data Sheet. AqQA 

calculates dissolved solids by summing the inorganic analytes, following 

by Standard Method 1030-E, except that it accounts for all of the 

inorganic analytes on the Data Sheet, and it accounts for carbonate 

specied as described in the next paragraph. 

The contribution of carbonate to dissolved solids is taken as the sum of 

the masses of analytes bicarbonate, carbonate, and carbon dioxide 

(HCO3,  CO3, and CO2). If none of these analytes is specified, AqQA 

accounts for carbonate in one of the following ways: (1) from an analyses 

of total carbon, (2) from the carbonate concentration calculating from a 

specified alkalinity and pH, as described below under Carbonate 
Speciation, or (3) from a specified alkalinity in the absence of pH, 

according to 0.6 × alkalinity. 

Density 

The program displays the water’s calculated density, in g/cm3, along with 

the measured value, if supplied on the Data Sheet. Density is calculated 

from salinity (dissolved solids expressed as permil salts) according to 

Standard Method 2520-C. AqQA calculates density only over the 

temperature range of 0°C–100°C. 

Electrical Conductivity 

The water’s calculated electrical conductivity, in mhos/cm, is displayed 

along with the measured value, if supplied on the Data Sheet. The 

temperature-corrected conductivity is calculated according to Standard 

Method 2510-A, accounting for ionic strength effects. 

Wherever possible, AqQA figures when calculating conductivity the 

speciation of carbonate to produce HCO3
− and CO3

−. AqQA also 

accounts for the contributions of the species H+ and OH−, whenever pH is 

specified. 
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Hardness 

The program reports three values calculated for hardness: total hardness, 

carbonate hardness, and non-carbonate hardness. Each value is given in 

mg/L as an equivalent amont of CaCO3. 

Total hardness is calculated from the Ca2+and Mg2+ content of the water 

from the equation 

Hardness [mg/L as CaCO3] = 2.497 [Ca2+, mg/L] + 4.118 [Mg2+, mg/L] 

as prescribed by Standard Method 2340-B. 

Carbonate hardness is the Ca2+ + Mg2+ that can be balanced by the 

amount of carbonate (i.e., HCO3
− + CO3

− + CO2) in solution. Ca2+ and 

Mg2+ precipitate as a carbonate mineral such as calcite, CaCO3 (i.e., Ca2+ 

+ HCO3
− → CaCO3 + H+), so one mole of carbonate balances one mole 

of Ca2+ + Mg2+. The carbonate hardness cannot exceed the total hardness, 

even if there’s more carbonate than Ca2+ + Mg2+ in solution. 

The non-carbonate hardness is total hardness less carbonate hardness. 

Internal Consistency 
The Internal Consistency category of the Data Analysis pane shows the 

results of seven quality assurance/quality control tests applied to the 

analysis of the water sample. A green “OK” identifies each test that was 

completed successfully. A red message such as “Not within ± 5%” is 

applied to unsuccessful results. In other cases, as noted, there is not 

enough information for the sample on the Data Sheet. 

The first six of the seven tests are described in 1030-E of the AWWA 

“Standard Methods” volume. Of the AWWA tests, the first three are 

considered of primary importance; the latter three may not be reliable for 

all water types. The final test checks for mass balance among organic 

analytes. The tests are: 

Anion-Cation Balance 

This test checks that the analysis honors the requirement that a water 

maintain electroneutrality. To make this test, the program figures the sum 

of the concentrations of the cations, expressed in meq/L, and the same 

value for the anions. This test is successful when the difference between 

the sums, or the percentage of the cation sum plus the anion sum that the 

difference represents, satisfies: 

Anion sum, meq/L Acceptable difference 

0–3 ± 0.2 meq/L 

3–10 ±2% 

10–800 ±5% 

Wherever possible, AqQA figures when calculating the anion sum the 

speciation of carbonate to produce HCO3
− and CO3

−. AqQA also 
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accounts for the contributions of the species H+ and OH− to the ion sums, 

whenever pH is specified. 

Measured TDS Matches Calculated TDS 

The ratio of the measured dissolved solids to the value calculated by 

Standard Method 1030-E, accounting for all inorganic analytes on the 

Data Sheet, should fall in the range 1.0 to 1.2. 

Measured Conductivity Matches Calculated Value 

The ratio of the measured electrical conductivity to the 

temperature-corrected value calculated by Standard Method 2510-A 

should fall in the range 0.9 to 1.1. 

Measured Conductivity and Ion Sums 

The ion sums for cations and anions multiplied by 100 should both fall 

within ±10% of the measured electrical conductivity. This test is 

considered by many to be less reliable and significant than the first three 

tests in this section. 

Calculated TDS to Conductivity Ratio 

The ratio of calculated dissolved solids (mg/L) to measured electrical 

conductivity (mhos/cm) should normally fall in the range 0.55 to 0.7. In 

the presence of poorly dissociated calcium or sulfate ions, the ratio may 

be as high as 0.8. This test is considered by many to be less reliable and 

significant than the first three tests in this section. 

Measured TDS to Conductivity Ratio 

The ratio of measured dissolved solids (mg/L) to measured electrical 

conductivity (mhos/cm) should fall in the range 0.55 to 0.7. This test is 

considered by many to be less reliable and significant than the first three 

tests in this section. 

Organic Carbon Cannot Exceed Sum of Organics 

This test compares a measured DOC (dissolved organic carbon, mg/L) 

value to the sum of the concentrations (mg/L, as C) of specific organic 

analytes. The DOC should not be more than 5% less than the sum. It 

may, however be greater, since all the organic species in solution have 

not necessarily been analyzed. 

Carbonate Equilibria 
The Carbonate Equilibria category show the speciation among carbonate 

ions in solution, and various factors that depend on the speciation. For 

details of how these calculations are performed, see Appendix: 
Carbonate Equilibria. 
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Dissolved carbonate is distributed among the carbonate and bicarbonate 

ions (CO3
− and HCO3

−) and aqueous carbon dioxide (CO2(aq)). In order 

for AqQA to figure the species distribution, the following conditions 

must be met for the sample: 

1. The pH must be specified. 

2. At least one measure of carbonate concentration must be 

specified. This may be (A) the concentration of one of the 

inorganic analytes bicarbonate, carbonate, or carbon dioxide, 

(B) the carbon concentration [C], or (C) the titration alkalinity. 

3. Temperature, which is set to 25°C if not specified, must fall in 

the range 0°C –300°C. (Note that in the range 100°C–300°C, it 

is necessary to specify fluid density directly, to avoid possibly 

significant calculation errors when converting units.) 

If these conditions are met, the following information will appear: 

Speciation 

The program reports the predicted distribution of carbonate among the 

three carbonate species: HCO3
−, CO3

−, and CO2. 

Total Carbonate From Titration Alkalinity 

If the titration alkalinity is given on the Data Sheet, the program reports 

the calculated total carbonate concentration. 

Titration Alkalinity From Total Carbonate 

If the carbonate concentration is given on the Data Sheet, the program 

reports the calculated titration alkalinity, in mg/kg as CaCO3. 

Mineral Saturation 

If the calcium concentration is given on the Data Sheet, the program 

reports the saturation indices calculated for the CaCO3 minerals calcite 

and aragonite. The saturation indices tell whether the minerals are 

supersaturated (SI > 0), saturated (SI = 0), or undersaturated (SI < 0). 

Partial Pressure of CO2 

The program shows the partial pressure of CO2 in the water, in atm. 

Irrigation Waters 
The following parameters are used to judge the suitability of a water for 

irrigating crops. Unless noted, concentrations (e.g., [Na]) are in units of 

meq/L. The program reports a value only in cases in which all of the 

necessary concentrations are given. 
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Salinity hazard 

This parameter is determined according to the following table. The 

program uses measured conductivity, if available, else measured 

dissolved solids, else calculated dissolved solids. 

 
Conductivity 

(mhos/cm) 

Dissolved solids 

(mg/L) 

Low salinity, no detrimental 

effects expected 
<250 <200 

Medium salinity, detrimental 

effects to sensitive crops 
250 – 750 200 – 500 

High salinity, adverse effects 

on many crops 
750 – 2250 500 – 1500 

Very high salinity, suitable 

only for salt tolerant plants 
2250 – 5000 1500 – 3000 

 

Sodium Adsorption Ratio 

The sodium adsorption ratio (SAR) is calculated according to 

  

where [] represents concentration in units of meq/L. 

Exchangeable Sodium Ratio 

The exchangable sodium ratio (ESR) is calculated according to 

  

where [] represents concentration in units of meq/L. 

Magnesium Hazard 

The magnesium hazard (MH) is calculated according to 

  

where [] represents concentration in units of meq/L. 

Residual Sodium Carbonate 

Residual sodium carbonate (RSC) is calculated according to 

RSC = ([CO3
−] + [HCO3

−]) – ([Ca2+] + [Mg2+]) 

2+ 2+

[Na ]

[Ca ] [Mg ]

2

SAR =
+

+

+

2+ 2+

[Na ]

[Ca ] [Mg ]
ESR =

+

2+

2+ 2+

[Mg ]
100

[Ca ] [Mg ]
MH = 

+
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where [] represents concentration in units of meq/L. 

Reference 

Lloyd, J.W. and J.A. Heathcote, 1985, Natural Inorganic Hydrochemistry 

in Relation to Groundwater, Oxford Press, Oxford, 296 pp. 

Geothermometry 

A geothermometer is a technique of estimating from a hydrothermal 

water’s composition the temperature at which the water last equilibrated 

with its environment. The techniques can be applied only to geothermal 

or hydrothermal waters; you should not attempt to apply them to normal 

ground or surface water. 

A number of geothermometers are implemented in AqQA. Each reflects 

differing assumptions about which minerals were in equilibrium with the 

water in question. Hence, the geothermometers invariably predict 

different temperatures. You should, therefore, not expect all of the 

temperatures to agree. Instead, choose one or more geothermometers 

appropriate for the conditions of interest. 

Each geothermometer has a temperature range of applicability; predicted 

temperatures falling outside this range are noted. If, for example, the 

maximum temperature is 250°C and the predicted value is 300°C, AqQA 

reports “>250°C”. The program, furthermore, can predict a temperature 

only in cases in which all of the necessary concentrations are given. 

In each case below, the geothermometer predicts temperature in °C from 

concentrations reported in mg/kg. In other words, [SiO2] is mg/kg silica 

in the fluid, and [Na/K] is the ratio of the Na concentration in mg/kg to 

the K concentration in mg/kg. 

Quartz (no 

steam loss)1 
 0 ≤ T ≤ 250°C 

Quartz (max. 

steam loss)1 
 0 ≤ T ≤ 250°C 

Chalcedony1  0 ≤ T ≤ 250°C 

-Cristobalite1  0 ≤ T ≤ 250°C 

-Cristobalite1  0 ≤ T ≤ 250°C 

Amorphous 

silica1 
 0 ≤ T ≤ 250°C 

2

1309
273.15

5.19 log[SiO ]
T = −

−

2

1522
273.15

5.75 log[SiO ]
T = −

−

2

1032
273.15

4.69 log[SiO ]
T = −

−

2

1000
273.15

4.78 log[SiO ]
T = −

−

2

781
273.15

4.51 log[SiO ]
T = −

−

2

731
273.15

4.52 log[SiO ]
T = −

−
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Na-K1  T > 150°C 

Na-K-Ca1 

 

 = 4/3 initially. If calculated T>100°C, or if 

[log(Ca½/Na)+2.06] < 0, recalculate using  = 1/3. 

0 ≤ T ≤ 300°C 

Na-K-Ca-Mg2 TNa-K-Ca + TMg, as described separately2 0 ≤ T ≤ 350°C 

Mg-Li2  0 ≤ T ≤ 350°C 

Na-Li2  0 ≤ T ≤ 350°C 

 

References: 

1Fournier, R.O., 1981, Application of water geochemistry to geothermal 

exploration and reservoir engineering. In L. Rybach and L.J.P. Muffler, 

eds., Geothermal Systems, Principles and Case Histories, Wiley, New 

York, p. 109-143. 

2Kharaka, Y.K. and R.H. Mariner, 1989, Chemical geothermometers and 

their application to formation waters from sedimentary basins. In N.D 

Naeser and T.H. McCulloh, eds., Thermal History of Sedimentary Basins, 

Springer-Verlag, New York, p. 99-117. 

Unit Conversion 
The final sections in the Data Analysis pane contain the chemical 

analysis in question, converted into a variety of concentration units and 

presented in a tabular format. 

These sections contain the following groups of units: 

Mass/Volume g/L, mg/L, μg/L, ng/L 

Equivalents/Volume eq/L, meq/L, μeq/L, neq/L 

Mass/Mass wt. %, g/kg, mg/kg, μg/kg, ng/kg 

Equivalents/Mass eq/kg, meq/kg, μeq/kg, neq/kg 

Moles/Mass mol/kg, mmol/kg, μmol/kg, nmol/kg 

Moles/Mass of Solvent molal, mmolal, μmolal, nmolal 

Moles/Volume molar, mmolar, μmolar, nmolar 

 

In the unit conversion, the following is observed: 

1217
273.15

1.483 log[Na/K]
T = −

+

1647

2.47 log[Na/K] log( Ca/Na) 2.06

273.15

T


=
 + + +
 

−

2200
273.15

5.47 log[ Mg/Li]
T = −

+

1590
273.15

0.779 log[Na/Li]
T = −

+
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1. The solution mass is the solvent mass plus the mass of the 

solute. 

2. The number of kg solution is the kg of solvent divided by 

(1 − 10−×TDS), where TDS is total dissolved solids in mg/kg. 

3. The number of kg solvent is the kg solution multiplied by 

(1 − 10−×TDS). 

4. Volume is mass divided by density, so L equals kg divided by 

density, where density is in g/cm3. 

5. An “equivalent” is the product of the number of moles of a 

dissolved species and the absolute value of the species’ 

electrical charge. An uncharged species invariably has an 

equivalent concentration of zero. 

Certain conversions, therefore, require knowledge of the sample’s 

density, TDS, or both. AqQA uses density and TDS values entered on the 

Data Sheet, if possible. 

If the density is not available, AqQA calculates a value from the solution 

salinity, according to Standard Method 2520-C. If the TDS is not 

available, the program calculates it by summing the dissolved masses of 

the various inorganic analytes. It is, therefore, important to enter a 

complete chemical analysis, so that density and TDS can be calculated 

correctly. 
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Replicates, Standards, and Mixing 

About Replicates, Standards, and Mixing 
AqQA® can help you evaluate the quality of your chemical analysis by 

checking replicate analyses, and analyses of known standards. It can also 

find the composition of a mixture of two or more of the samples on your 

Data Sheet. 

Comparing Replicate Analyses 
Replicate analyses are made on splits of the same sample. The splits are 

analyzed more than once, whether by the same or different labs. Since 

each replicate analysis is made on the same fluid, the analyses should 

agree to within a small margin of error. 

To check agreement among replicate samples, go to the Data Sheet and 

select two or more samples. (To do so, click on the marker for the first 

sample, then hold down the ctrl key and click on the markers for the 

remaining samples.) 

Select Samples → Compare Replicates, or click on the  button on 

the toolbar. A new display appears at the right side of the Data Sheet, or 

along the bottom if you have transposed it. 

The display shows the coefficient of variation for each analyte, and 

whether this value falls within a certain tolerance. Small coefficients of 

variation indicate good agreement among the replicates. 

Analytes with a coefficient of variation that does not fall within the 

tolerance are flagged by a red X. The tolerance, by default, is ±5, but you 

can change it by clicking on Samples → Set Replicate Tolerance… (or 

right-clicking on the replicate display and selecting this option) and 

entering a different value. 

To disable the replicate display at the right or bottom of the Data Sheet, 

re-select Samples → Compare Replicates, or click again on the  

button. To maintain the display, select Samples → Freeze Mix and 

Compare, or click on the  button. 
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Checking Against Standards 
A standard is a sample of well-known composition, one that was 

prepared synthetically or whose composition has already been analyzed 

precisely. A chemical analysis of the standard, then, should agree with 

the known composition to within a small margin of error. 

To check the analysis of a standard, enter both the standard’s known 

composition and the results of analyzing the standard in the Data Sheet. 

Select the known composition and click on Samples → Designate As 

Standard, or the  button. A check mark will appear on the Data Sheet 

next to the standard’s label. 

Select the standard’s analysis and click on Samples → Compare To 

Standard, or the  button. The display at the right or bottom of the 

Data Sheet shows the error in the analysis, relative to the standard. If you 

select more than one sample to compare to the standard, the program 

shows the average error. 

Analytes with errors  that do not fall within a specified tolerance are 

flagged by a red X. The tolerance, by default, is ±10, but you can change 

it by clicking on Samples → Set Tolerance… (or right-clicking on the 

standard display and selecting this option) and entering a different value. 

To disable the display, re-select Samples → Compare To Standard, or 

click again on the  button. To maintain the display, select Samples → 

Freeze Mix and Compare, or click on the  button. 

Fluid Mixing 
To calculate the composition of a mixture of samples, select on the Data 

Sheet the samples you want to mix. Click on Samples → Mix, or the  

button on the toolbar. The composition of the mixed fluid is shown in a 

new display at the right or bottom of the Data Sheet. 

The mixed composition contains each analyte which is conservative 

during mixing. Ion compositions such as Na+ and SO4
2-, for example, are 

conservative, but pH is not. In other words, mixing a pH 5 water with a 

pH 7 water does not yield a mixture of pH 6. 

To save the mixed fluid as a new sample on the Data Sheet, click on 

Samples → Save Mixture, or on the  button. To disable the display, 

re-select Samples → Mix, or click again on the  button. To maintain 

the display, select Samples → Freeze Mix and Compare, or click on 

the  button. 
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Graphing Data 

About Graphing Data 
To make a graph in AqQA, you follow these steps: 

• On the Data Sheet, select the data you want to appear on the 

plot. (Don’t worry, you can change your choices later.) For 

example, you might select the row of data for an analyte, or just 

the data in that row for certain samples. 

• Click on the  tab, along the bottom of the AqQA 

window and select a plot type. 

• Alter the content and appearance of the plot by changing the 

settings in the control panel along the right side of the AqQA 

plot pane, or by clicking on the Advanced Settings… button. 

You can delete the current plot by selecting Graphs → Delete Graph, or 

by right clicking on the plot pane’s tab, along the bottom of the AqQA 

window. To change the plot to another type, select Graphs → Change 

Graph Type, or right-click on the pane’s tab. 

Many of the graphs AqQA produces account for the calculated speciation 

of carbonate among carbon dioxide, bicarbonate ion, and carbonate ion. 

If you, for example, report alkalinity and pH, the program will figure the 

concentrations of the various ions and produce a graph reflecting them. 

The Piper, Durov, Schoeller, Bar Chart, Radial, and Stiff diagrams work 

this way. 

For each of these diagrams except the Piper and Durov plots, you can 

choose instead to plot the carbonate concentrations as they are entered on 

the Data Sheet. To do so, click on the Advanced Settings… button, then 

on the tab corresponding to the diagram type, and de-select the “Show 

carbonate speciation” option. 

Time Series Plots 
Time Series plots are much like Series plots, except that the horizontal 

axis shows the sampling date or time. You click on  and select 

Time Series Plot, which produces a graph like: 
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To make this type of plot, you must include in your Data Sheet either the 

Date or Time analyte, or both. 

Series Plots 
Series plots show one or more analytes on the vertical axis, and the 

samples in the Data Sheet along the horizontal. You can select the 

analytes to appear in the plot in the control panel along the right side of 

the AqQA window, as well as the samples to include. 

 

Time Series Plot
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Note that you can include any number of analytes, provided they have the 

same type of unit. For example, you can plot any combination of analytes 

expressed in terms of concentration, but you can’t include pH. 

You can set a log scale on the vertical axis by clicking on 

Advanced Settings… and selecting that option on the  pane. 

Cross Plots 
To make a cross plot, click on  and select Cross Plot. The graph 

will look like: 

 

You can select the analytes to appear on the axes, as well as the samples 

to include in the plot on the Data Sheet, before making the plot, or along 

the right side of the plot pane. 

Clicking on Advanced Options… on the control panel, you can set the 

axes to linear and logarithmic scales, and choose to superimpose a 

regression line on the plot. 

Ternary Diagrams 
Ternary (or trilinear) diagrams show sample composition in terms of 

three analytes. For example: 
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Set the three axes and samples to include on the Data Sheet, or in the 

control panel along the right of the pane. You also set the units on the 

control panel. 

Piper Diagrams 
Piper diagrams show the major ion compositions of any number of 

samples: 

 

Select the samples to include on the Data Sheet, or on the control panel to 

the right of the plot pane. Click on the  button on the control panel to 

include all of the samples from the Data Sheet. 
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Durov Diagrams 
Durov diagrams represent the major ion composition, pH, and TDS 

content of any number of samples: 

 

Select the samples to include on the Data Sheet, or on the control panel to 

the right of the plot pane. You control the pH and TDS ranges on the plot 

by clicking on Advanced Options… and moving to the  pane. 

Schoeller Diagrams 
Schoeller diagrams represent the compositions of any number of samples 

in diagrams that look like: 
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Select the samples to include on the Data Sheet, or on the control panel to 

the right of the plot pane. You set the units and value range for the 

vertical axis by clicking on Advanced Options… and moving to the 

 pane. 

Stiff Diagrams 
Stiff diagrams show the composition of a single sample, in terms of 

common cation and anions, with concentration represented in electrical 

equivalents. Select a sample on the Data Sheet, then select Stiff Diagram 

on the  pulldown menu. A Stiff diagram looks like: 

 

You can cycle through the samples on the Data Sheet by clicking on the 

 and  buttons. 

Radial Plots 
Radial plots are similar to Stiff diagrams, except that composition is 

plotted along axes arrayed like spokes on a wheel. They look like: 
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Ion Balance Diagrams 
Ion balance diagrams show the cationic and anionic composition of a 

sample, in terms of electrical equivalents. You select a sample on the 

Data Sheet and make a graph by clicking on  and choosing Ion 

Balance Diagram. The diagrams look like: 

 

Unlike the ion balance calculations on the Data Analysis pane, AqQA ion 

balance diagrams do not include the effects of carbonate speciation, nor 

do they account for the free concentrations of the ions H+ and OH−. 

 

Pie Charts 
Pie charts are similar to ion balance diagrams, except that ion 

concentrations are represented in terms of electrical equivalents as 

wedges that fit together into a circle. Example: 
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Unlike the ion balance calculations on the Data Analysis pane, AqQA pie 

charts do not include the effects of carbonate speciation, nor do they 

account for the free concentrations of the ions H+ and OH−. 

Copying a Graph to Another Document 
To copy a graph to another document, move to the AqQA pane 

containing the graph in question and select Edit → Copy, or touch 

ctrl+C. This will copy the graphic image to the clipboard. Now move to 

the target application and paste the image into your document. 

You will be able to edit the graphic elements of the image as you would 

any vector graphic. To do so, select the graphic in your illustration 

program and then select the ungroup option. You may need to ungroup 

the graphic twice. 

You can also copy the image to the clipboard as a bitmap, instead of as 

vector graphics, by selecting Edit → Copy As Bitmap. You will be able 

to edit the image as a bitmap, using programs such as Microsoft® Paint or 

Adobe® Photoshop®. 

Saving Graphs 
You can save any graph you make in AqQA as a graphic image that you 

can later edit in an illustration program, or import into other documents. 

Once you have created a graph you wish to save, make sure you are on 

the AqQA pane containing the graph and click on File → 

Save Image As…. 

On the resulting dialog, you can save the graphic image as a Windows® 

Enhanced Metafile, a Windows® bitmap, an Encapsulated PostScript 

(EPS) file, a JPG file or a PNG file. Enhanced Metafiles are convenient 

formats for importing to Microsoft® Office® files, such as PowerPoint® 

presentations and Word® documents. EPS files can be opened directly for 

editing in Adobe® Illustrator®. 

To edit an AqQA graphic in an illustration program, you select it and 

then ungroup its graphic elements. You may need to ungroup the object 

twice. 
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Tapping AqQA®’s Power 

About Tapping AqQA®’s Power 
As you become proficient with AqQA®, you will want to take advantage 

of more of its capabilities. The sections below explain how to do so. 

 

Template for New Data Sheets 

When you create a new AqQA document by selecting File → New, the 

initial, empty AqQA Data Sheet that appears is a “template”. A template 

is simply a .aqq file, generally containing a list of analytes, but no data. 

When you install the AqQA software, the default template is included in 

“C:\ProgramData\RockWare\AqQA”. The default template is named 

“default.aqq”. 

You may want to create your own template, or several, for the AqQA 

documents you create. For example, you may want to set a special list of 

analytes, in a certain order, with specific units. 

To do so, create a new AqQA Data Sheet (File → New) and configure it 

as you wish. Save the file in a convenient location (File → Save As…). 

Open the Preferences dialog by selecting File → Preferences… . In the 

box labeled Template for New Data Sheets, click on the Browse… 

button, and select the .aqq file you have just saved.  

If you maintain several templates, you can change among them in this 

manner. 

Exporting the Data Sheet 
You may wish to export the contents of the data sheet to another 

program, such as Microsoft® Excel®. To do so, select File → Export 

Data… . From this dialog, you can choose to save the data as a tab 

delimited or comma delimited text file, which you can open in Excel. 



     

     

 

48 • Tapping AqQA®’s Power A User's Guide to AqQA®  

     

     

 

Subscripts, Superscripts, and Greek Characters 
You can include superscripts, subscripts, and greek letters in character 

strings in your AqQA document. To set a character as superscript, for 

example, highlight it, right-click, and select Superscript. 

You set subscripts, unscripted characters (neither subscript not 

superscript), greek, and roman characters in the same fashion. 

Analyte Symbols 
AqQA by default labels analytes by name, using strings such as 

“Sodium”, “Potassium”, “Dissolved Solids”, and so on. You can also 

view analytes by their familiar chemical symbols: “Na”, “K”, “TDS”, 

etc. 

To change between viewing analytes by name or symbol, toggle the 

View → Show Analyte Symbols switch. 

Colors and Markers 
Each analyte can have associated with it a color and a marker, as can 

each sample. The color and data marker are used when creating graphs. 

By default, AqQA chooses the color and marker automatically, but you 

can associate specific choices with a given analyte or sample. 

To assign a color and marker to an analyte, select it (or more than one), 

then choose a color from Analytes → Analyte Color, and a marker from 

Analytes → Analyte Marker. Alternatively, select one or more analytes 

and right-click to choose the color and marker. 

Similarly, assign a color and marker to one or more samples by clicking 

on Samples → Sample Color, and a marker from Samples → Sample 

Marker, or by right-clicking. 

Calculated Ions 
AqQA can in its graphs display the concentrations of several “calculated 

ions” such a Na+ + K+, the sum of the sodium and potassium ions, and 

HCO3
− + CO3

−, the sum of the bicarbonate and carbonate ions. By 

selecting Graphs → Calculated Ion Settings…, you can change the 

label, color, and symbol associated with each of these analytes. 

Hiding Analytes and Samples 
If your Data Sheet contains a large number of samples or analytes, you 

may wish to temporarily exclude some of your data from being 

displayed. 

To hide one or more samples, select the samples to hide and select 

Samples → Hide. To restore the display, select Samples → Show All. 
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Similarly, to hide or re-display analytes in the Data Sheet, select 

Analytes → Hide and Analytes → Show All. 

Selecting Display Fonts 
You can change the fonts and font sizes in the Data Sheet and Data 

Analysis panes to suit your needs. Open the Preferences dialog (select 

File → Preferences…). In the boxes labeled Data Sheet and Data 

Analysis, you can select the font and point size for each pane. 

Searching the Data Sheet 

To search the Data Sheet for a character string, select Edit → Find… 

and enter the string in the dialog box that appears. You can then search 

forward or backward for the next occurrence of the string by selecting 

Edit → Find Next or Edit → Find Previous. 

Arrow Key Behavior During Editing 
When you are editing a field in the Data Sheet, the left and right arrow 

keys on your keyboard can function in one of two ways: they can move 

to the preceding or next character in the field, or the can move to the 

preceding or next field in the Data Sheet. 

You can set the behavior you prefer by opening the Preferences dialog 

(select File → Preferences…). In the box labeled Data Sheet, select the 

option you prefer. You can toggle between options at any time by 

touching Shift+F2. 

Sorting Samples and Analytes 
You can use AqQA’s sort function to arrange the rows and columns in 

your Data Sheet. To sort the samples, select Samples → Sort… and 

choose an option under Sort by:. Depending on the option you select, 

you can sort sample rows or columns according to any of the analytes on 

your Data Sheet, such as Sample ID, the date or time, or by the numerical 

value of any of the chemical analytes. 

To sort the analytes on your Data Sheet, select Analytes → Sort. This 

function will arrange the analytes in alphabetical order within the various 

categories (Inorganic, Organic, and so on). 

“Tip of the Day” 
When you start AqQA, a dialog box appears with a suggestion on how to 

use various features in the program. If you grow tired of seeing this “tip 

of the day”, uncheck the box labeled Show Tips at Startup. 

You can resume seeing tips by re-selecting this option on the Preferences 

dialog (select File → Preferences…). 
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Appendix: Carbonate Equilibria 

About Carbonate Equilibria 
This Appendix describes how AqQA® accounts for carbonate equilibria 

when figuring alkalinity, carbonate mineral saturation, CO2 partial 

pressure, and so on. 

AqQA assumes that a water’s carbonate concentration [Tot-CO3] is 

distributed among the three chemical species CO2(aq), HCO3
−, and 

CO3
−. In general, [Tot-CO3] is the sum of the individual species 

concentrations, or [HCO3] + [CO2] + [CO3]. In this section, the notation 

[] refers to molal concentration. 

Necessary Data 
To account for carbonate equilibria, AqQA needs to find on the Data 

Sheet a value for pH as well as a measure of the total carbonate 

concentration [Tot-CO3]. 

AqQA takes the value for [Tot-CO3] from an analysis reported for 

bicarbonate, carbonate, or carbon dioxide (or the molar sum of these 

values, if more than one is specified). If none of these analytes is present 

on the Data Sheet, AqQA takes [Tot-CO3] as the carbon concentration, 

assuming that most of the carbon in solution is present in oxidized form. 

Lacking an analysis for carbon, the program figures [Tot-CO3] from a 

reported value for alkalinity 

Activity Coefficients 

Each species in solution has an activity coefficient , calculated as 

follows. The solution’s ionic strength is determined in molal units by 

summing over the charged inorganic analytes, according to 

 

Here, mi is the species’ molal concentration and zi is its electrical charge 

(i.e., 2 for Ca2+, –1 for HCO3
−, etc.). Wherever possible, AqQA in 

calculating ionic strength accounts for the speciation of carbonate to form 

the species HCO3
− and CO3

−. The program also accounts for the 

contributions of the species H+ and OH−, where pH is known. 

21

2
i iI m z= 
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For each charged species (everything except CO2(aq)), the activity 

coefficient i is given by the extended Debye-Hückel equation 

 

where zi is its electrical charge and is the ion size parameter: 

  

CO3
− 4.5 

H+ 9 

HCO3
− 4.5 

Ca2+ 6 

 

The values of A and B vary with temperature (°C) according to 

A =  .4922 + .0003714 T + 1.083×10− T2 − 4.821×10− T3 

+ 1.208×10− T4 

and 

B =  .3247 + .0001224 T + 7.658×10− T2 − 2.908×10− T3 

+ 5.507×10− T4 

The activity coefficient for the uncharged ion CO2(aq) is taken as one. 

Apparent Equilibrium Constants 
The apparent equilibrium constants (K') for the reactions among the three 

species are calculated from the actual equilibrium constants (K) and the 

species’ activity coefficients, according to 

CO2(aq)  + H2O   H+  + HCO3
− 

 

log K1 =  −6.549 + .009002 T − .0001021 T2               

                  + 2.762×10−7 T3 − 3.561×10−10 T4 

 

 

and 

HCO3
−   CO3

−  + H+ 

 

log K2 =  −10.61 + .01277 T − .0001203 T2 

                 + 3.017×10−7 T3 − 2.694×10− T4 
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Here, T represents temperature in °C. 

Speciation 
AqQA calculates the distribution of carbonate among the species by 

rewriting the mass action equations above as follows: 

 

and 

 

Then, the mass balance equation 

 

can be expressed 

 

Knowing the pH and the free concentration of the HCO3
− species, then, 

AqQA uses this equation to calculate the total carbonate concentration 

directly. Likewise, knowing pH and [Tot-CO3], it calculates the HCO3
− 

concentration 

 

and from it the concentrations of CO2(aq) and CO3
−. 

Titration Alkalinity 
Titration alkalinity is a measure of the ability of a water to resist 

acidification as strong acid is added. The two species HCO3
− and CO3

− 

are taken to provide alkalinity. Each mole of HCO3
− can neutralize one 

equivalent of acid by reacting to form CO2(aq), and each mole of CO3
− 

can likewise neutralize two equivalents of acid. 

Titration alkalinity is generally reported as an equivalent mass of CaCO3 

per kg solution, even though CaCO3 isn’t involved in an alkalinity 

titration. Each mole of CaCO3 can neutralize two equivalents of acid, and 

the mole weight of calcium carbonate is 100.09 g/mol. Hence, the 

alkalinity in units of mg CaCO3/kg solution is related to the molal 

concentrations of the two species by 
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Or, substituting, 

 

The free HCO3
− concentration, then, can be calculated from the alkalinity 

according to 

 

From this value, the free concentrations of CO3
− and CO2(aq) can be 

determined immediately. 

Mineral Saturation 
The minerals calcite and aragonite have the same chemical composition 

(CaCO3), but different chemical structures. The saturation indices of 

these minerals 

SI = log Q/K = log Q – log K 

tells whether they are supersaturated (SI > 0), saturated (SI = 0), or 

undersaturated (SI < 0). Here, Q is the ion activity product, and K the 

equilibrium constant. 

For calcite, the reaction 

Calcite   Ca2+ + CO3
2- 

has an equilibrium constant vs. T (°C) given by 

log K =  −8.539  − .001499 T − .0001263 T2 

             + 4.477×10− T3 − 6.883×10− T4 

For aragonite, the reaction and equilibrium constant are 

Aragonite  Ca2+ + CO3
2- 

  

log K =  −8.371  − .001671 T − .0001253 T2 

            + 4.466×10− T3 − 6.884×10− T4 

In each case, the ion activity product is determined by the activity 

coefficients and molal concentrations of the CO3
− and Ca2+ species: 

Q = CO3 [CO3
2-] × Ca [Ca2+] 

and the saturation index follows from the definition above. 
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CO2 Partial Pressure 
Knowing the free concentration of CO2(aq), the partial pressure of carbon 

dioxide can be calculated immediately from the reaction 

CO2(g)   CO2(aq) 

The log equilibrium constant for this reaction is given as a function of T 

(°C) as 

log K =  −1.134  − .01363 T + 6.614×10− T2 

          − 1.286×10− T3 + 7.348×10− T4 

Since the activity coefficient for CO2 is unity, 

 

the CO2 partial pressure (in atm units) is 
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